Bug 200377 - pango rebuild fails after upgrade to freetype-2.1.4-4.0.rhel3.2.i386.rpm
pango rebuild fails after upgrade to freetype-2.1.4-4.0.rhel3.2.i386.rpm
Status: CLOSED DUPLICATE of bug 200033
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: freetype (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 06:19 EDT by Jan Kees
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 13:44:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kees 2006-07-27 06:19:01 EDT
Description of problem:
After upgrading from freetype-2.1.4-4.0.i386.rpm and
freetype-devel-2.1.4-4.0.i386.rpm to freetype-2.1.4-4.0.rhel3.2.i386.rpm and
freetype-devel-2.1.4-4.0.rhel3.2.i386.rpm it is no longer possible to rebuild
pango-1.2.5-5.src.rpm.

Version-Release number of selected component (if applicable):
freetype-2.1.4-4.0.rhel3.2.i386.rpm
freetype-devel-2.1.4-4.0.rhel3.2.i386.rpm
pango-1.2.5-5.src.rpm

How reproducible:
always

Steps to Reproduce:
1. rpm -Uvh freetype-2.1.4-4.0.rhel3.2.i386.rpm
freetype-devel-2.1.4-4.0.rhel3.2.i386.rpm
2. rpmbuild --rebuild pango-1.2.5-5.src.rpm
3. 
  
Actual results:
ftxgdef.c:863:46: macro "FT_MEM_REALLOC" requires 4 arguments, but only 3 given
ftxgdef.c: In function `Make_ClassRange':
ftxgdef.c:863: `FT_MEM_REALLOC' undeclared (first use in this function)
ftxgdef.c:863: (Each undeclared identifier is reported only once
ftxgdef.c:863: for each function it appears in.)
make[3]: *** [ftxgdef.lo] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/pango-1.2.5/pango/opentype'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/pango-1.2.5/pango'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/pango-1.2.5'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.99614 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.99614 (%build)


Expected results:
build of pango-1.2.5-5.i386.rpm and pango-devel-1.2.5-5.i386.rpm
(works fine after downgrading to freetype version 2.1.4-4.0)

Additional info:
Comment 1 Ray Strode [halfline] 2006-07-27 13:44:57 EDT

*** This bug has been marked as a duplicate of 200033 ***

Note You need to log in before you can comment on or make changes to this bug.