Bug 200408 - rhythmbox crashes with GTK-Error
rhythmbox crashes with GTK-Error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Monty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 10:58 EDT by Joseph Sacco
Modified: 2013-10-20 18:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-29 11:38:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Sacco 2006-07-27 10:58:19 EDT
Updated rawhide today [27July06].  rhythmbox-0.9.5.2 now crashes on startup witj
a Gtk error:

$ rhythmbox
NameOwnerChanged org.gnome.Rhythmbox ->:1.20

Gtk-ERROR **: file gtktreemodelfilter.c: line 2237
(gtk_tree_model_filter_get_path): assertion failed: (i < level->array->len)


The bug-buddy output is shown below.

-Joseph

==========================================================================

Distribution: Fedora Core release 5.91 (FC6 Test2)
Gnome Release: 2.15.4 2006-07-12 (Red Hat, Inc)
BugBuddy Version: 2.15.0

Memmory status: size: 25440256 vsize: 0 resident: 94044160 share: 0 rss:
94044160 rss_rlim: 0
CPU usage: start_time: 255850548 rtime: 0 utime: 1154012529 stime: 0 cutime:259
cstime: 0 timeout: 214 it_real_value: 0 frequency: 45

Backtrace was generated from '/usr/bin/rhythmbox'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 805479760 (LWP 26469)]
[New Thread 840348848 (LWP 26476)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x0fce02c0 in __waitpid_nocancel () from /lib/libpthread.so.0
#0  0x0fce02c0 in __waitpid_nocancel () from /lib/libpthread.so.0
#1  0x0e81ab5c in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x0fe69590 in raise () from /lib/libc.so.6
#4  0x0fe6b164 in abort () from /lib/libc.so.6
#5  0x0d82ef98 in g_logv () from /lib/libglib-2.0.so.0
#6  0x0d82f018 in g_log () from /lib/libglib-2.0.so.0
#7  0x0d82f0bc in g_assert_warning () from /lib/libglib-2.0.so.0
#8  0x0e22898c in gtk_tree_model_filter_convert_path_to_child_path ()
   from /usr/lib/libgtk-x11-2.0.so.0
#9  0x0e223f30 in gtk_tree_model_get_path () from /usr/lib/libgtk-x11-2.0.so.0
#10 0x0e229d50 in gtk_tree_model_filter_convert_child_iter_to_iter ()
   from /usr/lib/libgtk-x11-2.0.so.0
#11 0x0e229e40 in gtk_tree_model_filter_convert_child_iter_to_iter ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0x0e223c58 in gtk_tree_model_iter_next () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x0e223c98 in gtk_tree_model_iter_next () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x0e2247c8 in gtk_tree_model_foreach () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x10047a8c in rb_sourcelist_get_type ()
#16 0x0dab3608 in g_cclosure_marshal_VOID__PARAM () from /lib/libgobject-2.0.so.0
#17 0x0daa393c in g_closure_invoke () from /lib/libgobject-2.0.so.0
#18 0x0dab87a4 in g_signal_override_class_closure () from /lib/libgobject-2.0.so.0
#19 0x0dab9afc in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#20 0x0dab9cc8 in g_signal_emit () from /lib/libgobject-2.0.so.0
#21 0x0daa9470 in g_object_class_override_property () from /lib/libgobject-2.0.so.0
#22 0x0daa4b3c in g_enum_register_static () from /lib/libgobject-2.0.so.0
#23 0x0daabfd4 in g_object_set_valist () from /lib/libgobject-2.0.so.0
#24 0x0daac208 in g_object_set () from /lib/libgobject-2.0.so.0
#25 0x10045960 in _rb_source_hide_when_empty ()
#26 0x0e125d8c in gtk_marshal_BOOLEAN__VOID () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x0daa393c in g_closure_invoke () from /lib/libgobject-2.0.so.0
#28 0x0dab87a4 in g_signal_override_class_closure () from /lib/libgobject-2.0.so.0
#29 0x0dab9afc in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#30 0x0dab9cc8 in g_signal_emit () from /lib/libgobject-2.0.so.0
#31 0x0e2229b0 in gtk_tree_model_row_inserted () from /usr/lib/libgtk-x11-2.0.so.0
#32 0x1009b710 in rhythmdb_query_model_remove_entry ()
#33 0x1009d9b8 in rhythmdb_query_model_new ()
#34 0x100b332c in rb_marshal_VOID__POINTER_POINTER ()
#35 0x0daa393c in g_closure_invoke () from /lib/libgobject-2.0.so.0
#36 0x0dab87a4 in g_signal_override_class_closure () from /lib/libgobject-2.0.so.0
#37 0x0dab9afc in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#38 0x0dab9cc8 in g_signal_emit () from /lib/libgobject-2.0.so.0
#39 0x1008d448 in rhythmdb_emit_entry_deleted ()
#40 0x0d8142c4 in g_hash_table_foreach () from /lib/libglib-2.0.so.0
#41 0x10090a98 in rhythmdb_error_quark ()
#42 0x10092d04 in rhythmdb_shutdown ()
#43 0x0d825138 in g_source_get_current_time () from /lib/libglib-2.0.so.0
#44 0x0d824a54 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#45 0x0d82875c in g_main_context_check () from /lib/libglib-2.0.so.0
#46 0x0d828bc4 in g_main_loop_run () from /lib/libglib-2.0.so.0
#47 0x0e121444 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#48 0x10021b90 in main ()
#0  0x0fce02c0 in __waitpid_nocancel () from /lib/libpthread.so.0
Comment 1 Joseph Sacco 2006-07-29 11:38:47 EDT
The problem appeared to be caused by some cruft in the dot files.  Removing
./gconf/apps/rhythmbox and .gnome2/rhythmbox resolved the issue.

-Joseph

Note You need to log in before you can comment on or make changes to this bug.