Bug 200430 - No files in "java-1.4.2-gcj-compat-plugin" package (?)
Summary: No files in "java-1.4.2-gcj-compat-plugin" package (?)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-27 17:08 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:46:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2006-07-27 17:08:41 UTC
Description of problem:
The "java-1.4.2-gcj-compat-plugin" package reports to contain no files.
At least this is issued when 'rpm -ql java-1.4.2-gcj-compat-plugin' is
executed.

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-plugin-1.4.2.0-40jpp_98rh

How reproducible:
Always.

Steps to Reproduce:
1. Install "java-1.4.2-gcj-compat-plugin-1.4.2.0-40jpp_98rh"
2. Type "rpm -q java-1.4.2-gcj-compat-plugin-1.4.2.0-40jpp_98rh"
  
Actual results:
"rpm" returns: "(contains no files)"

Expected results:
"rpm" returns a list of file names

Additional info:
Querying the content of the uninstalled package yields the same
result. However, the plugin itself is functional!

Comment 1 Thomas Fitzsimmons 2006-07-27 17:46:55 UTC
java-1.4.2-gcj-compat-plugin installs the alternatives-managed
/usr/lib/mozilla/plugins/libjavaplugin.so symlink to
/usr/lib/gcj-4.1.1/libgcjwebplugin.so.  Unfortunately for rpm -q,
alternatives-managed symlinks must not be owned by the package since they are
removed in the %postun section.



Note You need to log in before you can comment on or make changes to this bug.