Bug 200432 - Clicking a link posted to a gaim chat causes firefox to open, and gaim to exit.
Clicking a link posted to a gaim chat causes firefox to open, and gaim to exit.
Status: CLOSED DUPLICATE of bug 200033
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gaim (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 13:13 EDT by Scott McBrien
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 00:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott McBrien 2006-07-27 13:13:51 EDT
Description of problem:
When you click a link within a gaim chat window, firefox will open the link, and
gaim will die.  Sometimes, just hovering the cursor over the link will cause
gaim to die.

Version-Release number of selected component (if applicable):
gaim-1.5.0-12.el4
firefox-1.0.8-1.4.1


How reproducible:
always

Steps to Reproduce:
1.Initiate an AIM connection to a buddy
2.Have the buddy send you a link in your chat pane
3.Attempt to click the link
  
Actual results:
If the link is clicked, firefox is invoked, gaim dies.  If the link is not
clicked, but the cursor is placed on the link, gaim dies.

Expected results:
gaim should not die.

Additional info:
Comment 1 Warren Togami 2006-07-27 15:09:13 EDT
http://gaim.sourceforge.net/gdb.php
Please install matching debuginfo and use this procedure to get a gdb traceback.

Use "run -d" and capture all of the debugging messages too.

Attach all of that as a text file in this report.
 
Comment 2 Scott McBrien 2006-07-28 15:21:40 EDT
From gdb debug package:

At the time of the error:
Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread -1209009952 (LWP 32520)]
0x004c601a in FT_Realloc () from /usr/lib/libfreetype.so.6

out of the bt full command:
#0  0x004c601a in FT_Realloc () from /usr/lib/libfreetype.so.6
No symbol table info available.
#1  0x0037e29b in TT_GSUB_Apply_String () from /usr/lib/libpangoft2-1.0.so.0
No symbol table info available.
#2  0x0037e4c3 in otl_buffer_add_glyph () from /usr/lib/libpangoft2-1.0.so.0
No symbol table info available.
#3  0x0037e879 in pango_ot_buffer_add_glyph ()
   from /usr/lib/libpangoft2-1.0.so.0
No symbol table info available.
#4  0x0367c321 in ?? () from /usr/lib/pango/1.4.0/modules/pango-arabic-fc.so
No symbol table info available.
#5  0x09f891c0 in ?? ()
No symbol table info available.
#6  0x000004fd in ?? ()
No symbol table info available.
#7  0x0000000e in ?? ()
No symbol table info available.
#8  0x00000000 in ?? ()
No symbol table info available.
Comment 3 Warren Togami 2006-07-31 00:15:08 EDT

*** This bug has been marked as a duplicate of 200033 ***

Note You need to log in before you can comment on or make changes to this bug.