Bug 200444 - echo c > /proc/sysrq-trigger does not cause a crash
echo c > /proc/sysrq-trigger does not cause a crash
Status: CLOSED DUPLICATE of bug 201618
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 14:17 EDT by Barry Donahue
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 10:34:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Donahue 2006-07-27 14:17:50 EDT
Description of problem:


Version-Release number of selected component (if applicable):

kernel 2.6.17-1.2358.fc6

How reproducible: always


Steps to Reproduce:
1.echo "1" > /proc/sys/kernel/sysrq
2.echo c > /proc/sysrq-trigger
3.You will get the message- SysRq : Trigger a crash dump -but the system doesn't
crash.
  
Actual results: no crash


Expected results:crash


Additional info: echo b and echo t do work.
Comment 1 Jeff Layton 2006-08-17 22:18:25 EDT
I've done a little poking around with systemtap and have determined that
crash_kexec() is getting called, but machine_crash_shutdown() is never called.
So either this is evaluating true:

xchg(&kexec_lock, 1);

...or this is evaluating false:

xchg(&kexec_crash_image, NULL);

Working on a debug patch to determine which it is...
Comment 2 Jeff Layton 2006-08-18 09:14:41 EDT
The problem seems to be that kexec_crash_image is NULL. Looking at how and when
that gets initialized.
Comment 3 Jarod Wilson 2006-08-18 10:34:29 EDT
Check out the latest patch attached to bug 201618. :)

*** This bug has been marked as a duplicate of 201618 ***
Comment 4 Jarod Wilson 2006-08-18 10:36:56 EDT
Actually, this might be closer to a dupe of bug 198578...

kexec_crash_image gets set by starting the kdump service, which loads your kdump
kernel via kexec.

Note You need to log in before you can comment on or make changes to this bug.