Bug 200449 - status and export issues with NFS HA filesystems
Summary: status and export issues with NFS HA filesystems
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager   
(Show other bugs)
Version: 4
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 180185
TreeView+ depends on / blocked
 
Reported: 2006-07-27 19:12 UTC by Corey Marthaler
Modified: 2009-04-16 19:52 UTC (History)
1 user (show)

Fixed In Version: RHBA-2006-0557
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 21:25:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0557 normal SHIPPED_LIVE rgmanager bug fix update 2006-08-10 04:00:00 UTC

Description Corey Marthaler 2006-07-27 19:12:08 UTC
Description of problem:
I have an nfs service consisting of one ext and one gfs fileystem and I'm
constantly seeing the following messages to logs:

Jul 27 14:04:41 tank-02 clurgmgrd[3920]: <notice> status on nfsclient "*"
returned 127 (unspecified)
Jul 27 14:04:41 tank-02 bash: [18742]: <info> Removing export: *:/mnt/tank1
Jul 27 14:04:41 tank-02 bash: [18742]: <info> Adding export: *:/mnt/tank1
(fsid=9468,rw)
Jul 27 14:04:41 tank-02 clurgmgrd[3920]: <notice> status on nfsclient "*"
returned 127 (unspecified)
Jul 27 14:04:41 tank-02 bash: [18850]: <info> Removing export: *:/mnt/tank2
Jul 27 14:04:41 tank-02 bash: [18850]: <info> Adding export: *:/mnt/tank2
(fsid=661,rw)
Jul 27 14:05:41 tank-02 clurgmgrd[3920]: <notice> status on nfsclient "*"
returned 127 (unspecified)
Jul 27 14:05:41 tank-02 bash: [19224]: <info> Removing export: *:/mnt/tank1
Jul 27 14:05:41 tank-02 bash: [19224]: <info> Adding export: *:/mnt/tank1
(fsid=9468,rw)
Jul 27 14:05:41 tank-02 clurgmgrd[3920]: <notice> status on nfsclient "*"
returned 127 (unspecified)
Jul 27 14:05:41 tank-02 bash: [19332]: <info> Removing export: *:/mnt/tank2
Jul 27 14:05:41 tank-02 bash: [19332]: <info> Adding export: *:/mnt/tank2
(fsid=661,rw)


Version-Release number of selected component (if applicable):
[root@tank-02 ~]# rpm -q rgmanager
rgmanager-1.9.52-0

Comment 1 Lon Hohberger 2006-07-27 20:05:09 UTC
127 means bash couldn't find a specified command.

Comment 2 Lon Hohberger 2006-07-28 17:27:04 UTC
There were spaces after backslashes in the shell code; I don't know how it got
there.

Logs with .52 version:


[root@green ~]# exportfs *:/tmp
[root@green ~]# exportfs -v
/tmp            <world>(ro,wdelay,root_squash)
[root@green ~]# OCF_RESKEY_target="*" OCF_RESKEY_name="foo" OCF_RESKEY_path=/tmp
/usr/share/cluster/nfsclient.sh  status
/usr/share/cluster/nfsclient.sh: line 340:  : command not found
/usr/share/cluster/nfsclient.sh: line 342: ^/tmp[\t ]*.*: No such file or directory
[root@green ~]# echo $?
127


Logs with new version:

[root@green ~]# exportfs -v
/tmp            <world>(ro,wdelay,root_squash)
[root@green ~]# OCF_RESKEY_target="*" OCF_RESKEY_name="foo" OCF_RESKEY_path=/tmp
/usr/share/cluster/nfsclient.sh  status
[root@green ~]# echo $?
0
[root@green ~]# exportfs -u *:/tmp
[root@green ~]# OCF_RESKEY_target="*" OCF_RESKEY_name="foo" OCF_RESKEY_path=/tmp
/usr/share/cluster/nfsclient.sh  status
[root@green ~]# echo $?
1



Comment 3 Lon Hohberger 2006-07-28 17:27:43 UTC
This is probably considered a regression since U3. :(

Comment 4 Corey Marthaler 2006-08-08 16:26:57 UTC
Lon what version is this supposedly fixed in?

I saw the "127" messages while testing on the "latest" today along with hung NFS
client I/O.


Aug  8 05:26:58 taft-02 clurgmgrd: [8326]: <debug> Checking 10.15.89.210, Level 0
Aug  8 05:26:58 taft-02 clurgmgrd: [8326]: <debug> 10.15.89.210 present on eth0
Aug  8 05:26:58 taft-02 clurgmgrd: [8326]: <debug> Link for eth0: Detected
Aug  8 05:26:58 taft-02 clurgmgrd: [8326]: <debug> Link detected on eth0
Aug  8 05:27:17 taft-02 kernel: CMAN: node taft-04 rejoining
Aug  8 05:27:18 taft-02 clurgmgrd[8326]: <notice> status on nfsclient "*"
returned 127 (unsp
Aug  8 05:27:18 taft-02 bash: [17669]: <info> Removing export: *:/mnt/taft1
Aug  8 05:27:18 taft-02 bash: [17669]: <info> Adding export: *:/mnt/taft1
(fsid=672,rw)
Aug  8 05:27:18 taft-02 clurgmgrd[8326]: <notice> status on nfsclient "*"
returned 127 (unsp
Aug  8 05:27:18 taft-02 bash: [17776]: <info> Removing export: *:/mnt/taft0
Aug  8 05:27:18 taft-02 bash: [17776]: <info> Adding export: *:/mnt/taft0
(fsid=3179,rw)


[root@taft-02 ~]# rpm -q rgmanager
rgmanager-1.9.51-0


Comment 5 Lon Hohberger 2006-08-08 21:47:43 UTC
It's wrong on your system, but correct in CVS/RHEL4U4 and CVS/RHEL4; maybe
somehow the last build didn't pick it up, or 1.9.51 isn't the latest build?



Comment 8 Corey Marthaler 2006-08-08 22:08:05 UTC
fix verified.

Comment 10 Red Hat Bugzilla 2006-08-10 21:25:23 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0557.html



Note You need to log in before you can comment on or make changes to this bug.