Bug 200493 - gnutls-devel needs to require pkgconfig
gnutls-devel needs to require pkgconfig
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnutls (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 01:46 EDT by Jeffrey C. Ollie
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 11:25:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Ollie 2006-07-28 01:46:05 EDT
Description of problem: gnutls-devel needs to require pkgconfig


Version-Release number of selected component (if applicable): 1.2.10-1


How reproducible: always


Steps to Reproduce:
1. Build a package that uses /usr/bin/libgnutls-config during the build process
2.
3.
  
Actual results:

checking for libgnutls-config... /usr/bin/libgnutls-config
checking for libgnutls - version >= 0.1.0... /usr/bin/libgnutls-config: line 11:
 pkg-config: command not found
/usr/bin/libgnutls-config: line 12: pkg-config: command not found
/usr/bin/libgnutls-config: line 13: pkg-config: command not found
/usr/bin/libgnutls-config: line 11: pkg-config: command not found
/usr/bin/libgnutls-config: line 12: pkg-config: command not found
/usr/bin/libgnutls-config: line 13: pkg-config: command not found
/usr/bin/libgnutls-config: line 11: pkg-config: command not found
/usr/bin/libgnutls-config: line 12: pkg-config: command not found
/usr/bin/libgnutls-config: line 13: pkg-config: command not found
no
*** Could not run libgnutls test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means LIBGNUTLS was incorrectly installed
*** or that you have moved LIBGNUTLS since it was installed. In the latter case, you
*** may want to edit the libgnutls-config script: /usr/bin/libgnutls-config

Expected results:

checking for libgnutls-config... /usr/bin/libgnutls-config
checking for libgnutls - version >= 0.1.0... yes

Additional info:
/usr/bin/libgnutls-config is a script that calls pkg-config.  With the upcoming
minimal buildroots, pkgconfig is no longer installed by default.
Comment 1 Tomas Mraz 2007-01-17 11:25:39 EST
Fixed in FC-6.

Note You need to log in before you can comment on or make changes to this bug.