Bug 200634 - denied messages from mingetty
denied messages from mingetty
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-29 08:15 EDT by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 14:02:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2006-07-29 08:15:56 EDT
+++ This bug was initially created as a clone of Bug #200633 +++

Description of problem:
dmesg shows denied messages for mingetty
Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.3.3-12
selinux-policy-2.3.3-12


How reproducible:
always

Steps to Reproduce:
1. Boot with selinux enabled
2. Check dmesg for avc denied messages
3.
  
Actual results:
audit(1154174480.095:8): avc:  denied  { write } for  pid=2397 comm="mingetty"
name="wtmp" dev=dm-0 ino=6359205 scontext=system_u:system_r:getty_t:s0
tcontext=system_u:object_r:var_log_t:s0 tclass=file
audit(1154174480.099:9): avc:  denied  { write } for  pid=2398 comm="mingetty"
name="wtmp" dev=dm-0 ino=6359205 scontext=system_u:system_r:getty_t:s0
tcontext=system_u:object_r:var_log_t:s0 tclass=file
audit(1154174480.103:10): avc:  denied  { write } for  pid=2401 comm="mingetty"
name="wtmp" dev=dm-0 ino=6359205 scontext=system_u:system_r:getty_t:s0
tcontext=system_u:object_r:var_log_t:s0 tclass=file
audit(1154174480.115:11): avc:  denied  { write } for  pid=2408 comm="mingetty"
name="wtmp" dev=dm-0 ino=6359205 scontext=system_u:system_r:getty_t:s0
tcontext=system_u:object_r:var_log_t:s0 tclass=file
audit(1154174480.267:12): avc:  denied  { write } for  pid=2407 comm="mingetty"
name="wtmp" dev=dm-0 ino=6359205 scontext=system_u:system_r:getty_t:s0
tcontext=system_u:object_r:var_log_t:s0 tclass=file
audit(1154174480.315:13): avc:  denied  { write } for  pid=2403 comm="mingetty"
name="wtmp" dev=dm-0 ino=6359205 scontext=system_u:system_r:getty_t:s0
tcontext=system_u:object_r:var_log_t:s0 tclass=file



Expected results:
No denied messages

Additional info:
System updated to 29-Jul-06 from devel
Comment 1 Daniel Walsh 2006-07-31 08:57:24 EDT
Some how wtmp has the wrong context on it.  It should be labeled wmpt_t.

restorecon /var/run/wtmp

Should fix the problem.  Any idea who/what recreated wtmp?
Comment 2 Jurgen Kramer 2006-08-02 15:33:03 EDT
You probably mean 'restorecon /var/log/wtmp' ? Using that fixes the problem.
This does not go away by itself, bug?
Comment 3 Jurgen Kramer 2006-08-04 14:49:01 EDT
Bug just reappaered :(

[kramer@macbook ~]$ ls /var/log/wtmp -lZ
-rw-rw-r--  root utmp system_u:object_r:var_log_t      /var/log/wtmp

audit(1154717439.772:9): avc:  denied  { write } for  pid=2405 comm="mingetty"
name="wtmp" dev=dm-0 ino=6357503 scontext=system_u:system_r:getty_t:s0
tcontext=system_u:object_r:var_log_t:s0 tclass=file

This is probably due to updated of selinux policy.
Comment 4 Jurgen Kramer 2006-09-11 14:02:07 EDT
I am not seeing this anymore. Fixed with newer policy.

Note You need to log in before you can comment on or make changes to this bug.