Bug 200669 - rpm database unrecoverble
rpm database unrecoverble
Status: CLOSED DUPLICATE of bug 200670
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
3
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 08:40 EDT by Sun Minchao
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-30 08:46:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sun Minchao 2006-07-30 08:40:25 EDT
Description of problem:
rpm database corrupted and unrecoverble

Version-Release number of selected component (if applicable):
rpm version 4.3.2

How reproducible:


Steps to Reproduce:
1.as root in single user mode: cd /var/lib/rpm
2.rm -f __db*
3.db_verify Packages (failed)
4.rpm --rebuilddb (failed)
  
Actual results:

[/var/lib/rpm] rm -f __db*
[/var/lib/rpm] db_verify Packages
db_verify: page 466: illegal page type or format
db_verify: page 466: illegal page type or format
db_verify: PANIC: Invalid argument
db_verify: Packages: pgin failed for page 466
db_verify: Packages: DB_RUNRECOVERY: Fatal error, run database recovery
db_verify: DB->verify: Packages: DB_RUNRECOVERY: Fatal error, run database
recovery
db_verify: PANIC: fatal region error detected; run recovery
db_verify: dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery
[/var/lib/rpm] mv Packages Packages.orig
[/var/lib/rpm] db_dump Packages.orig | db_load Packages
db_dump: page 466: illegal page type or format
db_dump: PANIC: Invalid argument
db_dump: Packages.orig: pgin failed for page 466
db_dump: DB->stat: DB_RUNRECOVERY: Fatal error, run database recovery
db_dump: PANIC: fatal region error detected; run recovery
db_dump: close: DB_RUNRECOVERY: Fatal error, run database recovery
db_dump: PANIC: fatal region error detected; run recovery
db_dump: dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery
db_load: line 4: unexpected format
[/var/lib/rpm] rpm --rebuilddb
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from dbenv->open: DB_RUNRECOVERY: Fatal error, run
database recovery
error: cannot open Packages index
[/var/lib/rpm]


Expected results:


Additional info:
the damaged /var/lib/rpm/Packages file is to large (39MB) to be attached here.
Comment 1 Sun Minchao 2006-07-30 08:46:46 EDT

*** This bug has been marked as a duplicate of 200670 ***

Note You need to log in before you can comment on or make changes to this bug.