Bug 200679 - starting metacity with composite enabled locks up the system
starting metacity with composite enabled locks up the system
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 14:42 EDT by Jurgen Kramer
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 22:56:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2006-07-30 14:42:59 EDT
Description of problem:
When starting metacity with composite enabled the system locks up after the
gnome splash screen shatters.

Version-Release number of selected component (if applicable):
metacity-2.15.5-6.1
xorg-x11-drv-i810-1.6.0-12.20060717modeset.fc6
mesa-libGLU-6.5-19.fc6
mesa-libGL-6.5-19.fc6

How reproducible:
always

Steps to Reproduce:
1. Enable composite with gconf-editor
2. Reboot system and log in again
3.
  
Actual results:
After the splash screen shatters the system lock up. Keyboard is completely
dead, only the mouse pointer can be moved. System has to be shutdown holding the
power buttong > 3 secs.

Expected results:
No lockup

Additional info:
When composite is enabled after logging in all the gl effects just work fine.
Comment 1 Joachim Frieben 2006-08-08 10:04:36 EDT
What happens, if you launch "gconf-editor" from the "GNOME" session
and checkmark the "composite" option? In principle, "metacity" should
switch to composite mode immediately which is obviously visible then.
No need to reboot your system, not even to log out.
Comment 2 Jurgen Kramer 2006-08-09 13:49:50 EDT
That works as advertised (as I mentioned in my bugreport @ Additional info). 

But:
opened windows from pup stay minimized. Alt-tab wont select them.

To find out if this was composite related I tried to disable the composite
checkbox again, it froze the machine instantly. 

After a hard boot the machine completely froze again while starting X. Reason:
composite was still enabled. I had to boot in level 3 and hand edit %gconf.xml
to fix it.

Comment 3 Matthias Clasen 2006-08-14 22:56:22 EDT
Closing bugs related to the metacity compositor, since we no longer develop it.

Note You need to log in before you can comment on or make changes to this bug.