Bug 200693 - mirrorlist download failures are silently ignored
Summary: mirrorlist download failures are silently ignored
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-31 01:23 UTC by Daniel Hokka Zakrisson
Modified: 2014-01-21 22:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-19 19:39:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch showing where the problem is (522 bytes, patch)
2006-07-31 01:23 UTC, Daniel Hokka Zakrisson
no flags Details | Diff

Description Daniel Hokka Zakrisson 2006-07-31 01:23:25 UTC
Description of problem:
If a mirrorlist fails to download and it's the only mirrorlist for that repo
(such as the default .repos from fedora-release), yum will fail with the
seemingly incorrect "Cannot find a valid baseurl for repo: <repo>". Even with
-d9 -e9, there is no indication of the mirrorlist download failing.


Version-Release number of selected component (if applicable):
yum-2.6.1-0.fc5
yum-2.9.3-2


How reproducible:
Always


Steps to Reproduce:
rm -f /etc/resolv.conf
iptables -I INPUT -j REJECT
etc.

  
Actual results:
Cannot find a valid baseurl for repo: core
Error: Cannot find a valid baseurl for repo: core


Expected results:
At the very least a warning with the URLGrabError exception for diagnostics.


Additional info:
The attached patch doesn't do the Right Thing(tm), but I couldn't figure out how
to use a Logger from getMirrorList.

Comment 1 Daniel Hokka Zakrisson 2006-07-31 01:23:25 UTC
Created attachment 133298 [details]
Patch showing where the problem is

Comment 2 Seth Vidal 2006-08-19 19:39:58 UTC
Fixed up in cvs - I added something similar to your patch.

thanks!



Note You need to log in before you can comment on or make changes to this bug.