Bug 200694 - Moving "Han-Yin" <-> Zhu-Yin" option to AUX UI
Moving "Han-Yin" <-> Zhu-Yin" option to AUX UI
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-chewing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 21:50 EDT by Leon Ho
Modified: 2008-03-10 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 00:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libchewing-0.3.0-5.bz200694.patch - proposed patch 1/2 (1.77 KB, patch)
2006-09-25 23:33 EDT, Caius Chance
no flags Details | Diff
scim-chewing-0.3.1-7.bz200694.patch - proposed patch 2/2 (3.40 KB, patch)
2006-09-25 23:34 EDT, Caius Chance
no flags Details | Diff

  None (edit)
Description Leon Ho 2006-07-30 21:50:39 EDT
Description of problem:
The issue is that both Han-Yin and Zhu-Yin are frequently used on different
regions who uses Traditional Chinese, but currently scim-chewing do not give an
easy way to switch between those two type of pinyins. Please contact with
upstream and see how feasible is it to implement this change.

Actual results:
- Configuration is in Keyboard setup in SCIM Setup menu

Expected results:
- Configuration should be in AUX UI.
Comment 1 Caius Chance 2006-09-19 22:51:08 EDT
Consulted upstream, they suggested to save the key everytime user clicks on the
button, and immeadiately reload the config because scim is not proactively check
the config when received input from user.
Comment 2 Caius Chance 2006-09-25 23:33:07 EDT
Created attachment 137104 [details]
libchewing-0.3.0-5.bz200694.patch - proposed patch 1/2

proposed patch.

libchewing is also needed to be patched as scim-chewing need a function to
return current keyboard type.
Comment 3 Caius Chance 2006-09-25 23:34:43 EDT
Created attachment 137105 [details]
scim-chewing-0.3.1-7.bz200694.patch - proposed patch 2/2

proposed patch.

could be improve the triggering button to drop menu like changing input method
engines.
Comment 4 Caius Chance 2006-09-25 23:36:18 EDT
Pending to propose patch to upstream.

Note You need to log in before you can comment on or make changes to this bug.