Bug 200710 - sniff work error
sniff work error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dogtail (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Zack Cerza
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 05:06 EDT by Yan Tian
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 23:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sniff of dogtail-0.5.1-1 run in Fc6-test2 and RHEL5-Alpha-RC-20060623.0/4.90 products (14.65 KB, image/png)
2006-07-31 05:15 EDT, Yan Tian
no flags Details

  None (edit)
Description Yan Tian 2006-07-31 05:06:28 EDT
Description of problem:
sniff of dogtail-0.5.2-1 cant't work in FC6-test2, RHEL4-U3 and
RHEL5-Alpha-RC-20060623.0/4.90 products.
sniff of dogtail-0.5.1-1 can't work in FC6-test2 and
RHEL5-Alpha-RC-20060623.0/4.90 and products.

Version-Release number of selected component (if applicable):
dogtail-0.5.2-1
dogtail-0.5.1-1

How reproducible:
always

Steps to Reproduce:
1.get dogtail-0.5.2-1 code from CVS
2.make rpm and install the binary rpm
3.run 'sniff'
  
Actual results:
same error in above three products:

[root@dhcp-0-178 dogtail]# rpm -q dogtail
dogtail-0.5.2-1
[root@dhcp-0-178 dogtail]# sniff
Detecting distribution: Red Hat/Fedora/derived distribution
Traceback (most recent call last):
  File "/usr/bin/sniff", line 7, in ?
    from dogtail import tree
  File "/usr/lib/python2.4/site-packages/dogtail/tree.py", line 1233, in ?
    root = Root (atspi.registry.getDesktop ())
  File "/usr/lib/python2.4/site-packages/dogtail/tree.py", line 378, in __init__
    self.__selection = self.__accessible.getSelection()
  File "pyspi.pyx", line 386, in atspi.Accessible.__getattr__
AttributeError: getSelection

Expected results:
catch the application and show the info successfully

Additional info:
Comment 1 Yan Tian 2006-07-31 05:15:24 EDT
Created attachment 133309 [details]
sniff of dogtail-0.5.1-1 run in Fc6-test2 and RHEL5-Alpha-RC-20060623.0/4.90 products
Comment 2 Yan Tian 2006-07-31 05:20:15 EDT
Steps to Reproduce:
1.get dogtail-0.5.1-1 code from dogtail website
2.make rpm and install the binary rpm
3.run 'sniff'
  
Actual results:
same error in FC6-test2 and RHEL5-Alpha-RC-20060623.0/4.90 products. Sniff run
but no list info of applications as attachment png file.

[root@dhcp-0-184 dogtail-0.5.1]# rpm -q dogtail
dogtail-0.5.1-1
[root@dhcp-0-184 dogtail-0.5.1]# sniff
Detecting distribution: Red Hat/Fedora/derived distribution
Warning: AT-SPI's desktop is visible but it has no children. Are you running any
AT-SPI-aware applications?

(Sniff:12848): libglade-WARNING **: could not find glade file 'sniff.glade'
/usr/bin/sniff:18: Warning: IA__g_object_get_valist: object class `GnomeProgram'
has no property named `default-icon'
  x = gtk.glade.XML('/usr/share/dogtail/glade/sniff.glade')

Expected results:
catch the application and show the info successfully
Comment 3 Zack Cerza 2006-08-23 12:54:41 EDT
Make sure dogtail and pyspi are the latest version. Also make sure you don't
have 2 copies of them installed at the same time ("rpm -q pyspi dogtail" should
show exactly 2 lines). Are you still seeing this problem?
Comment 4 Yan Tian 2006-08-23 22:03:29 EDT
In rhel4-u3 system:
Rhel4-U3 system had no dogtail and pyspi packages. So I was used to downloaded
code from website for stable version or CVS for newer version. I installed one
version package after uninstalled another version package.

dogtail-0.5.1-1 and pyspi-0.5.4-1 worked well.

Latest version of pysqi from CVS 'make rpm' error for needing "libX11-devel"
package.

Latest version of dogtail from CVS 'make rpm' successfully but installation failed. 
[root@dhcp-0-188 dist]# rpm -ivh dogtail-0.5.3-1.noarch.rpm
error: Failed dependencies:
        pyspi >= 0.5.5 is needed by dogtail-0.5.3-1.noarch
        xorg-x11-server-Xvfb is needed by dogtail-0.5.3-1.noarch
        xorg-x11-xinit is needed by dogtail-0.5.3-1.noarch


In Rhel5 and rawhide system:
I had reported bug 202407.
Comment 5 Zack Cerza 2006-08-24 12:43:52 EDT
This bug is filed against the devel version of Fedora Extras. After FC5, dogtail
and pyspi are in Fedora Core. To install the newest versions of dogtail and
pyspi on Fedora Core 5+, just 'yum install pyspi dogtail'. See if you can
reproduce the problem with pyspi-0.5.5-1 and dogtail 0.5.2-3.

For RHEL4:

Install xorg-x11-server-Xvfb and xorg-x11-xinit. Then download these:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/source/SRPMS/pyspi-0.5.5-1.fc6.src.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/development/source/SRPMS/dogtail-0.5.2-3.fc6.src.rpm

and rebuild them with rpmbuild --rebuild <foo>.rpm

Install the RPMs it builds, and see if you can reproduce the problem.
Comment 6 Yan Tian 2006-08-25 01:18:18 EDT
Description of problem:
yum pyspi and dogtail in FC6-test2 system, sniff work error, dogtail-record work
well

Version-Release number of selected component (if applicable):
pyspi-0.5.5-1.fc6
dogtail-0.5.2-3.fc6

How reproducible:
always

Steps to Reproduce:
1.rpm -q pyspi dogtail
2.yum install pyspi dogtail
3.rpm -q pyspi dogtail
4.run 'sniff'
5.run 'dogtail-recorder'
  
Actual results:
1.[root@dhcp-0-184 ~]# rpm -q pyspi dogtail
pyspi-0.5.4-1
dogtail-0.5.2-1

2.successfully

3.[root@dhcp-0-184 ~]# rpm -q pyspi dogtail
pyspi-0.5.5-1.fc6
dogtail-0.5.2-3.fc6

4.[root@dhcp-0-184 ~]# sniff
Detecting distribution: Red Hat/Fedora/derived distribution
Traceback (most recent call last):
  File "/usr/bin/sniff", line 7, in ?
    from dogtail import tree
  File "/usr/lib/python2.4/site-packages/dogtail/tree.py", line 78, in ?
    raise ImportError, "Error importing the AT-SPI bindings"
ImportError: Error importing the AT-SPI bindings

5.[root@dhcp-0-184 ~]# dogtail-recorder
GTK Accessibility Module initialized
Detecting distribution: Red Hat/Fedora/derived distribution

(Recorder:7413): libglade-WARNING **: could not find glade file 'recorder.glade'
#!/usr/bin/python
from dogtail.procedural import *


(Recorder:7413): libglade-WARNING **: could not find glade file 'textinput.glade'
focus.application('/usr/bin/dogtail-recorder')
click('Input Text', roleName='push button')
focus.dialog('')
click('OK', roleName='push button')
focus.application('gedit')
focus.widget('', roleName='text')
focus.widget.text = "test string"
click('', roleName='text', raw=True)
click('', roleName='text', raw=True)
click('File', roleName='menu')
click('New', roleName='menu item')
focus.application('/usr/bin/dogtail-recorder')
click('Quit', roleName='push button')
Segmentation fault

Expected results:
step 3.sniff can catch the application and show the info successfully

Additional info:
Comment 7 Zack Cerza 2006-09-14 16:52:34 EDT
I built new dogtail and pyspi packages last night that should fix this.
Comment 8 Yan Tian 2006-09-18 03:39:43 EDT
test in RHEL5-Client-20060915.0(i386) Workstation system:
1.rpm -q pyspi dogtail
pyspi-0.5.5-1.fc6
dogtail-0.5.2-3.fc6
sniff and dogtail-recorder can't still work.

2.get source code from CVS, compile for getting binary package, update new
version package
  pyspi-0.6.0-1
  dogtail-0.6.0-1
sniff and dogtail-recorder can work.
Comment 9 Zack Cerza 2006-09-18 11:20:30 EDT
Ugh, I guess the new packages didn't get put into the weekly build. The next one
should have them, though.
Comment 10 Yan Tian 2006-10-17 22:32:58 EDT
Verified it has been fixed in RHEL5-Client-20061012.9 System.
Comment 11 Yan Tian 2006-10-17 23:12:07 EDT
Verified in pyspi-0.6.0-2.fc6, dogtail-0.6.0-1.fc6.

Note You need to log in before you can comment on or make changes to this bug.