Bug 200713 - [gedit] Dynamic save changes doesn't reflect on opened file in gedit.
[gedit] Dynamic save changes doesn't reflect on opened file in gedit.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Desktop, i18n
: 200715 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 05:36 EDT by Satyabrata Maitra
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 23:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2006-07-31 05:36:48 EDT
Description of problem:
If the same file open in gedit and any other editors simultaneously, the changes
made and save for file opened in other editor doesn't reflet in gedit ( until
the file is closed and reopen in gedit again or made change file open in gedit
and attempt to save it).

Version-Release number of selected component (if applicable):
gedit-2.15.4-1

How reproducible:
Always

Steps to Reproduce:
1. Open a file with gedit
2. Open same file with any other editor like vi, kedit, kate etc.
3. Change the file content opened in the editors other than gedit
4. Save the change.
5. see the same file opened in gedit
6. No message shows after the same file has been changed until gedit is closed  
   and reopened again.
  
Actual results:
gedit doesn't reflect the file contents changed and saved by other editors
dynamically.

Expected results:
Whatever the change made and saved in file open in other editor, should reflect
in the same file open in gedit immediately after change saved in other editor
and when activate the gedit window after that.

Additional info:
If do the same for any file opened in kate, kate editor shows message that file
has been changed by other editor and give option to user to choose the action on
chage made on other editor for the same file.
Comment 1 Matthias Clasen 2006-07-31 12:19:08 EDT
*** Bug 200715 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Clasen 2006-08-03 23:32:15 EDT
Feature requests like this are best filed in upstream bugzilla.gnome.org. 
In fact, there is already a bug that seems to fit the bill:

http://bugzilla.gnome.org/show_bug.cgi?id=75861

Note You need to log in before you can comment on or make changes to this bug.