Bug 200726 - [mail][si_LK] unable to enter "kRoo" (2nd modifier) in composer with scim-sinhala
[mail][si_LK] unable to enter "kRoo" (2nd modifier) in composer with scim-sin...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: i18n
: 203911 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 08:04 EDT by A S Alam
Modified: 2013-07-02 20:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-12 08:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broken rendering again (2.57 KB, image/png)
2006-09-14 06:33 EDT, Mayank Jain
no flags Details

  None (edit)
Description A S Alam 2006-07-31 08:04:13 EDT
Description of problem:
when try to input for Sinhala Language, then failed to render properly

Version-Release number of selected component (if applicable):
evolution-2.7.4-3

How reproducible:


Steps to Reproduce:
1. Open Evolution
2. New Mail
3. Ctrl + Space to input 
  
Actual results:
rendering is broken

Expected results:
Rendering should like Gedit

Additional info:
Comment 1 A S Alam 2006-07-31 08:06:42 EDT
for input,
please install scim-sinhala (from rawhide) and press following keys

"kRoo"
Ctrl+Space to activative and Deactivate Input method
Comment 2 Mayank Jain 2006-08-08 04:27:19 EDT
Mail composer in ascii mode displays on typing "kRoo" with scim-sinhala as
කරඔඔ
While the correct representation should have been
ක්‍රෝ
Comment 3 Mayank Jain 2006-09-02 05:46:20 EDT
Initial investigation...

This seems to be a gtkhtml bug as the composer editor is a gtkhtml widget.

File - $evo/composer/e-msg-composer.c
/* Editor component.  */
p->eeditor = bonobo_widget_new_control (GNOME_GTKHTML_EDITOR_CONTROL_ID,
bonobo_ui_component_get_container (p->uic));


Also, in the same file, I found that evo just handles the ESC key & passes all
other events back to gtkhtml3 for processing.

static int
composer_key_pressed (EMsgComposer *composer, GdkEventKey *event, void *user_data)
{
	if (event->keyval == GDK_Escape) {
		do_exit (composer);
		g_signal_stop_emission_by_name (composer, "key-press-event");
		return TRUE;
	}
	
	return FALSE;
}
Comment 4 Mayank Jain 2006-09-02 08:10:05 EDT
Aman, I just checked this on Rawhide, this seems to be fixed. Can you confirm &
close the bug?

Thanks,
Mayank
Comment 5 Mayank Jain 2006-09-02 08:19:38 EDT
This *might* have fixed the bug...
http://cvs.gnome.org/viewcvs/gtkhtml/src/gtkhtml.c?r1=1.623&r2=1.624
Comment 7 Mayank Jain 2006-09-14 06:33:07 EDT
Found it to be broken again in 
evolution-2.8.0-1.fc6
scim-sinhala-0.2.0-1.fc6
pango-1.14.3-1.fc6
Comment 8 Mayank Jain 2006-09-14 06:33:27 EDT
Created attachment 136247 [details]
broken rendering again
Comment 9 Leon Ho 2006-09-26 08:29:51 EDT
Mayank, is it duplicate of 206261?
Comment 10 Akira TAGOH 2006-09-26 10:57:02 EDT
better trying with GTK_IM_MODULE=scim. then you can see if it's relevant to
#206261. if still happens, then just copy the broken strings and paste to gedit
say and see how it's displayed. if IM sends the correct character code sequqnce
but just gtkhtml's rendering is broken, copy-and-psate should works and gedit
should renders it properly, because whether IM works properly and applications
is rendering the characters properly is different issue. and since the input on
other languages works fine on evo's composer, it might be an issue in IM if
copy-and-paste doesn't work.
Comment 11 Mayank Jain 2006-09-28 07:07:53 EDT
Hi Leon,

"ii", "oo", "uu", "dH" are 1st modifier problems while "kRoo" are 2nd modifier
problems. Hence as per Tyronne, this bug is not duplicate of bug 206261.

206261 is for 1st modifiers & this bug is for second modifier. However, the
reason for both of them *might* be same. 

IMO, lets keep this open & simultaneously keep on following Bug 206261.

Comment 12 Jens Petersen 2006-09-29 12:17:09 EDT
I also suspect this is a duplicate of bug 206261
and indeed can reproduce this with latest scim-bridge.
Comment 13 Jens Petersen 2006-09-29 12:18:53 EDT
(In reply to comment #12)
> ... can reproduce this with latest scim-bridge.

Sorry, CAN'T reproduce with scim-bridge-0.4.5-3.fc6.
Comment 14 Jens Petersen 2006-09-29 12:21:57 EDT
*** Bug 203911 has been marked as a duplicate of this bug. ***
Comment 15 A S Alam 2007-04-12 08:35:36 EDT
it was working same for gedit and Evolution,
tested with following packages:
evolution-2.10.1-2.fc7
pango-1.16.2-1.fc7
scim-bridge-0.4.10-1.fc7

Thanks

Note You need to log in before you can comment on or make changes to this bug.