Bug 200756 - freenx will not work if dbus-x11 is not installed, but it is not a dependency.
freenx will not work if dbus-x11 is not installed, but it is not a dependency.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard A. Stout
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 10:48 EDT by Andrew Speer
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: freenx-0.5.0-4.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 13:35:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Speer 2006-07-31 10:48:01 EDT
Description of problem:

freenx will not work if dbus-x11 is not installed, but it is not a dependency.

Version-Release number of selected component (if applicable):

0.5.0-2.fc5

How reproducible:

Every time

Steps to Reproduce:
1. Install freenx without dbus-x11 package, 
2 .Configure clients to use kde
3 .Clients will be able to authenticate but session will not start.

Additional info:

The nxloadconfig file (part of freenx) contains references to dbus-launch in the
 COMMAND_START_KDE and COMMAND_START_GNOME variables. If dbus-launch is not
available neither desktop environment will start. 

There are no clear errors indicating that the missing dbus-launch is the problem
 when this occurs, which make it hard for the average user to troubleshoot. 

Action:

Suggest adding dbus-x11 as a dependency in the freenx package.

Thanks,

Andrew Speer
Comment 1 Till Maas 2006-08-29 11:20:31 EDT
this seems to be fixed in release 4:

$ rpm -qR freenx | grep dbus-x11
dbus-x11

Note You need to log in before you can comment on or make changes to this bug.