Bug 200783 - xen installation fails with "lvcreate failed for LogVol00"
xen installation fails with "lvcreate failed for LogVol00"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks: 200124
  Show dependency treegraph
 
Reported: 2006-07-31 12:58 EDT by James Morris
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 07:19:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump (59.48 KB, text/plain)
2006-07-31 12:58 EDT, James Morris
no flags Details

  None (edit)
Description James Morris 2006-07-31 12:58:42 EDT
Description of problem:

Anaconda text installation of a xen guest (via xenguest-install.py) fails with
"lvcreate failed for LogVol00"

Version-Release number of selected component (if applicable):

xen-3.0.2-22
anaconda is whatever is currently in gromit


Additional info:
- DNS seems to be flaky, too.  Had to specify install location as an IP address,
and it couldn't start vnc because it couldn't determine the address for localhost.

See attachement.
Comment 1 James Morris 2006-07-31 12:58:43 EDT
Created attachment 133331 [details]
Anaconda dump
Comment 2 Jeremy Katz 2006-07-31 13:05:35 EDT
The LVM tools are segfaulting in matchpathcon_init when SELinux is enabled --
selinux=0 works around, but obviously that's not a good long-term solution.  

Unfortunately, really being able to debug this sanely means getting a guest
installed and then we hit but 200127
Comment 3 Jeremy Katz 2006-08-01 13:07:49 EDT
Okay, not lvm2's fault. 

In libselinux, there's a __thread variable.  When we reference it, lvm.static
segfaults.  Easy reproducer is to install kernel-xen on an x86 box, boot into
it, run '/sbin/lvm.mkstatic vgmknodes'

Which starts to make me think this is something in the TLS fixup code in xen,
but not sure yet.
Comment 5 Jeremy Katz 2006-08-01 15:35:11 EDT
This should be fixed with new libselinux + lvm2
Comment 6 James Morris 2006-09-18 22:21:02 EDT
works fine now

Note You need to log in before you can comment on or make changes to this bug.