This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 200802 - weak-modules did not process kernel
weak-modules did not process kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
Brian Brock
:
: 200897 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 14:47 EDT by Brian Brock
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 02:54:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2006-07-31 14:47:26 EDT
installing kernel-xen-2.6.17-1.2478.fc6.i686 results in the error message "****
weak-modules did not process this kernel ****"

2.6.17-1.2473.fc6xen running


kernel-xen-2.6.17-1.2478.fc6.i686
rawhide-20060728 + updates to rawhide-20060731
module-init-tools-3.3-0.pre1.4.6

$)-> rpm -ihv kernel-xen-2.6.17-1.2478.fc6.i686.rpm 
Preparing...                ########################################### [100%]
   1:kernel-xen             ########################################### [100%]
**** weak-modules did not process this kernel ****
weak-updates links not updated for 2.6.17-1.2478.fc6xen
Please run /sbin/weak-modules --add-kernel `uname -r`
in order to update kernel module compatibility links.

running `/sbin/weak-modules --add-kernel 2.6.17-1.2478.fc6xen` results in the
same error message being printed again.
Comment 1 Jon Masters 2006-08-01 02:54:12 EDT
There was an erroneous assumption in my script that the RPM database would be
populated with the newly installed kernel by the post stage. I've fixed the
script and respun module-init-tools, and asked for it to be tagged for FC6T2.
Comment 2 Jon Masters 2006-08-01 10:11:40 EDT
*** Bug 200897 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.