This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 200820 - mknod in anaconda shell is broken
mknod in anaconda shell is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 16:23 EDT by Roland McGrath
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 16:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for isys.makedev wrapper (672 bytes, patch)
2006-07-31 16:23 EDT, Roland McGrath
no flags Details | Diff

  None (edit)
Description Roland McGrath 2006-07-31 16:23:04 EDT
Description of problem:

The mknod written in python for the anaconda emergency shell is broken.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.73-1

How reproducible:
100%

Steps to Reproduce:
1. mknod sda15 b 8 15
2.
3.
  
Actual results:

sh-3.1# mknod sda15 b 8 15
/usr/bin/mknod:50: DeprecationWarning: isys.makedev is deprecated.  Use
os.makedev instead.
  isys.mknod(path, 0644 | type, isys.makedev(major, minor))
/usr/bin/mknod:50: DeprecationWarning: isys.mknod is deprecated.  Use os.mknod
instead.
  isys.mknod(path, 0644 | type, isys.makedev(major, minor))
Traceback (most recent call last):
  File "/usr/bin/mknod", line 53, in ?
    main()
  File "/usr/bin/mknod", line 50, in main
    isys.mknod(path, 0644 | type, isys.makedev(major, minor))
  File "/usr/lib/anaconda/isys.py", line 388, in mknod
    return os.mknod(pathname, mode, dev)
TypeError: an integer is required


Expected results:

no error, create the node

Additional info:

The script should be fixed not to use the deprecated interfaces.
It fails because isys.makedev is broken.  Patch attached.
Comment 1 Roland McGrath 2006-07-31 16:23:04 EDT
Created attachment 133350 [details]
fix for isys.makedev wrapper
Comment 2 Peter Jones 2006-07-31 16:31:47 EDT
Will be fixed in the next rawhide build

Note You need to log in before you can comment on or make changes to this bug.