Bug 2008230 - wsjtx-2.5.0 is available
Summary: wsjtx-2.5.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wsjtx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-27 15:59 UTC by Upstream Release Monitoring
Modified: 2021-11-04 01:33 UTC (History)
2 users (show)

Fixed In Version: wsjtx-2.5.0-1.fc36 wsjtx-2.5.0-1.fc33 wsjtx-2.5.1-1.fc35 wsjtx-2.5.1-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-18 17:17:04 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2021-09-27 15:59:18 UTC
Latest upstream release: 2.5.0
Current version/release in rawhide: 2.4.0-4.fc35
URL: http://physics.princeton.edu/pulsar/k1jt/wsjtx.html

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/16118/

Comment 1 Richard Shaw 2021-10-13 15:57:13 UTC
$DAYJOB has been limiting my spare cycles as of late but I have created some test packages. I'm having the no audio/RF issue with my Yaesu FT-991A so I've been hesitant to build official packages, but it may not be a problem across the board if you have time to work on it.

Comment 2 Jaroslav Škarvada 2021-10-13 16:15:47 UTC
(In reply to Richard Shaw from comment #1)
> $DAYJOB has been limiting my spare cycles as of late but I have created some
> test packages. I'm having the no audio/RF issue with my Yaesu FT-991A so
> I've been hesitant to build official packages, but it may not be a problem
> across the board if you have time to work on it.

I can check with my radios, but only on f33. Isn't the problem related to the pipewire (f34 and up)?

Comment 3 Richard Shaw 2021-10-13 16:18:51 UTC
I surprisingly didn't have any issues with Fldigi or WSJT-X (at least on 2.4.0), but it could be part of the problem.

Comment 4 Jaroslav Škarvada 2021-10-13 23:57:38 UTC
(In reply to Richard Shaw from comment #3)
> I surprisingly didn't have any issues with Fldigi or WSJT-X (at least on
> 2.4.0), but it could be part of the problem.

It works OK for me on f33. I checked only FT8. I used the following scratch build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=77197780

Comment 5 Jaroslav Škarvada 2021-10-14 23:37:38 UTC
(In reply to Jaroslav Škarvada from comment #4)
> (In reply to Richard Shaw from comment #3)
> > I surprisingly didn't have any issues with Fldigi or WSJT-X (at least on
> > 2.4.0), but it could be part of the problem.
> 
> It works OK for me on f33. I checked only FT8. I used the following scratch
> build:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=77197780

I used it to successfully work S9OK expedition with the nearly mirror report, so for me it seems it works OK :). The only problem I spotted is that the 'auto log' feature doesn't work and I had to click the 'log QSO' button which is quite annoying. I guess this change is intentional, but I wasn't able to find anything related in the changelog. I am tempted to patch it out :)

Are you going to do more testing? Or can I build it and push it to the testing? Unfortunately, I am currently unable to test it with the PipeWire, but hopefully I will be able to do it soon :).

Comment 6 Richard Shaw 2021-10-17 16:22:46 UTC
I'm using hamlib with the flrig "rig". I built test packages in a new COPR and now when I try 2.4.0 or 2.5.0 I only get rapid relay clicking when using the "tune" button in WSJT-X and it randomly loses connection to hamlib.

I don't think it's an audio issue since I can turn the output all the way down and it does the same thing. Also, Fldigi works perfectly.

Comment 7 Richard Shaw 2021-10-17 16:59:15 UTC
It looks like it's hamlib<-->flrig that's broke. I setup my FT-991A directly in WJST-X and it appears to work fine so far.

Comment 8 Richard Shaw 2021-10-17 17:02:04 UTC
So I think it's safe to build everything, BUT... With the f35 beta freeze going on I wonder if we should? I'm also working on updating hamlib to the latest version. I was going to coordinate the update of 2.5.0 at the same time.

Comment 9 Richard Shaw 2021-10-17 18:31:11 UTC
Per the feedback from the devel mailing list looks like it's OK to build. Do you want me to take care of it while I'm updating hamlib?

Comment 10 Jaroslav Škarvada 2021-10-18 08:46:37 UTC
(In reply to Richard Shaw from comment #9)
> Per the feedback from the devel mailing list looks like it's OK to build. Do
> you want me to take care of it while I'm updating hamlib?

OK, no problem I will update it (wsjtx).

Are you experiencing the problems with the old (4.2) or new hamlib (4.3.1)?

For me with the Icom the CAT and the remote tuning worked without any regression.

Comment 11 Richard Shaw 2021-10-18 12:38:26 UTC
I tested both with 4.1 and 4.3.1 with the same result this time. Rapid relay clicking when trying to TX but Test PTT works fine. Switched from Flrig "radio" to my actual radio and it works fine.

Comment 12 Jaroslav Škarvada 2021-10-18 16:36:45 UTC
(In reply to Richard Shaw from comment #11)
> I tested both with 4.1 and 4.3.1 with the same result this time. Rapid relay
> clicking when trying to TX but Test PTT works fine. Switched from Flrig
> "radio" to my actual radio and it works fine.

So the problem is probably not in the hamlib. Maybe the problem is in the fldigi or in the way how wsjtx uses hamlib (if this is not reproducible with the older wsjtx)?

Comment 13 Fedora Update System 2021-10-18 17:13:36 UTC
FEDORA-2021-1d52a9badb has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1d52a9badb

Comment 14 Fedora Update System 2021-10-18 17:17:04 UTC
FEDORA-2021-1d52a9badb has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2021-10-18 18:26:47 UTC
FEDORA-2021-89b655463d has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-89b655463d

Comment 16 Fedora Update System 2021-10-18 18:27:08 UTC
FEDORA-2021-6c3f55caf8 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-6c3f55caf8

Comment 17 Fedora Update System 2021-10-18 18:27:29 UTC
FEDORA-2021-fd0fbd4bea has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-fd0fbd4bea

Comment 18 Fedora Update System 2021-10-19 00:48:44 UTC
FEDORA-2021-6c3f55caf8 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-6c3f55caf8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-6c3f55caf8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2021-10-19 01:29:16 UTC
FEDORA-2021-fd0fbd4bea has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-fd0fbd4bea`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-fd0fbd4bea

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2021-10-20 13:47:31 UTC
FEDORA-2021-89b655463d has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-89b655463d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-89b655463d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2021-10-26 15:42:37 UTC
FEDORA-2021-62c33c5ec1 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-62c33c5ec1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-62c33c5ec1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2021-10-27 02:28:13 UTC
FEDORA-2021-0b28112902 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-0b28112902`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-0b28112902

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Fedora Update System 2021-10-27 03:04:24 UTC
FEDORA-2021-fd0fbd4bea has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 24 Fedora Update System 2021-11-03 01:11:48 UTC
FEDORA-2021-62c33c5ec1 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 25 Fedora Update System 2021-11-04 01:33:13 UTC
FEDORA-2021-0b28112902 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.