Bug 20086 - Installer reboots before finishing install. Has happened twice.
Installer reboots before finishing install. Has happened twice.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i586 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-31 04:16 EST by Gustav Axelsson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-18 13:17:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Installer dumped this file (876 bytes, text/plain)
2000-10-31 04:17 EST, Gustav Axelsson
no flags Details

  None (edit)
Description Gustav Axelsson 2000-10-31 04:16:22 EST
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1631, in
doInstall
    self.fstab.write (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 740, in write
    iutil.mkdirChain(prefix + mntpoint)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 193, in
mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 17] Filen existerar: '/mnt/sysimage/home'
//Filen existerar = File exists (Swedish language)

Local variables in innermost frame:
which: 4
dir: /mnt/sysimage/home
elements: ['', 'mnt', 'sysimage', 'home']
path: /mnt/sysimage/home

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>
Comment 1 Gustav Axelsson 2000-10-31 04:17:21 EST
Created attachment 4815 [details]
Installer dumped this file
Comment 2 Michael Fulbright 2000-10-31 11:14:01 EST
Did you choose to format all partitions? It seems like the /home directory was
present already on your root partition.
Comment 3 Gustav Axelsson 2000-11-01 10:09:30 EST
Yes I choose to format all the partitions.

They were already present because I had RH 6.1 before.
I thought it was best to do a complete install rather than to upgrade from 6.1
to 7.0.
Comment 4 Michael Fulbright 2000-11-14 15:09:50 EST
What partitions and mount points are you using for the install?
Comment 5 Gustav Axelsson 2000-11-18 02:42:06 EST
I solved the problem. It was my harddrives fault, something was wrong with it,
that's why it never remembered such things as mount points.
The harddrive probably gave the installer wrong information at one point or another.

Thanks for all the help!

(I used /, /usr, /boot and /home. The partitions was somewhat strange, it looked
like an extended DOS partition. I removed all partitions using FDISK under
ms-dos and re-created them during the RH Linux installation while no other
partitions existed. It worked.)
Comment 6 Brock Organ 2000-12-18 13:17:32 EST
glad to hear you got it all sorted out ... thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.