Bug 200876 - [ml_IN] Inscript keyboard layout is not selecting from scim table.
[ml_IN] Inscript keyboard layout is not selecting from scim table.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-m17n (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mayank Jain
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 03:28 EDT by Satyabrata Maitra
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 04:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
corrected ml-inscript.mim file (4.77 KB, application/octet-stream)
2006-08-01 04:35 EDT, Mayank Jain
no flags Details

  None (edit)
Description Satyabrata Maitra 2006-08-01 03:28:45 EDT
Description of problem:
Inscript keyboard layout in malayalam is not selecting from scim table lists. If
attempt to select it, it is showing English/Keyboard.

Version-Release number of selected component (if applicable):
scim-m17n-0.2.0-5.fc6
m17n-db-malayalam-1.3.3-14.fc6
scim-libs-1.4.4-9.2.fc5
scim-qtimm-0.9.4-5
scim-pinyin-0.5.91-11.3.fc6
scim-fcitx-3.1.1-5.fc6
scim-bridge-gtkimm-0.1.12-1.fc6
scim-input-pad-0.1.1-4.fc6
scim-bridge-gtkimm-0.2.6-1.fc6
scim-libs-1.4.4-25.fc6
scim-devel-1.4.4-25.fc6
scim-fcitx-tools-3.1.1-5.fc6
scim-bridge-0.2.6-1.fc6
scim-doc-1.4.4-25.fc6

How reproducible:
Always

Steps to Reproduce:
1. Run Command LANG=ml_IN.UTF-8 gedit &
2. Press CTRL+SPACE to enable SCIM
3. Select Malayalam -> inscript
4. Observe the result
  
Actual results:
Inscript is not selecting.

Expected results:
inscript should select.

Additional info:
Comment 1 Mayank Jain 2006-08-01 03:58:04 EDT
Just confirming this behaviour... on my rawhide.
Comment 2 Mayank Jain 2006-08-01 04:32:43 EDT
Just rechecked the comments added in the "description" segment of the keymap &
found some double quote characters (") not escaped. Escaping them made the
keymap work

However, this is very strange... as i've myself seen the keymap previously working. 

Jensp, has there been any change in how the parser of m17n-db files handles the
description segment?
Comment 3 Mayank Jain 2006-08-01 04:35:28 EDT
Created attachment 133379 [details]
corrected ml-inscript.mim file

working ml-inscript file, tested with scim-1.4.4-25.fc6
Comment 4 Jens Petersen 2006-08-01 04:49:24 EDT
> However, this is very strange... as i've myself seen the keymap previously
working. 

After the description was modified?

> Jensp, has there been any change in how the parser of m17n-db files handles the
> description segment?

Nope.  
Comment 5 Mayank Jain 2006-08-01 05:20:16 EDT
Build sent to rawhide, smaitra, please check.
Thanks,
Mayank
Comment 6 Satyabrata Maitra 2006-08-01 05:23:44 EDT
Thanks. Ok, I will retest this one with the latest rawhide tomorrow.
Comment 7 Mayank Jain 2006-08-01 06:12:19 EDT
Also, the problem of selecting ml-inscript & scim-panel showing english can be
resolved by adding 
/DefaultIMEngineFactory/ml_IN = IMEngine-M17N-tl-inscript
to ~/.scim/config

I think jensp can help us in this as ~/.scim/config is generated by scim.

Jensp, can you please comment?

Thanks,
Mayank
Comment 8 Mayank Jain 2006-08-01 06:14:24 EDT
Oops, thats
/DefaultIMEngineFactory/ml_IN = IMEngine-M17N-ml-inscript
Comment 9 Jens Petersen 2006-08-01 07:29:58 EDT
Comment 7 is covered by bug 197058.
Comment 10 Mayank Jain 2006-08-01 08:04:41 EDT
As far as I tested it, just updating the m17n-db-malayalam rpm should solve this
problem.
Smaitra, please test it with updating the rpm, without doing any changes to
~/.scim/config file.

Thanks,
Mayank
Comment 11 Satyabrata Maitra 2006-09-01 01:58:46 EDT
The Problem is fixed now. inscript layout can be selected from the scim list now
in malayalam.

Component Version tested :

scim-m17n-0.2.0-6.fc6
m17n-db-malayalam-1.3.3-17.fc6
scim-1.4.4.32.fc6

Note You need to log in before you can comment on or make changes to this bug.