Bug 200880 - openssl-0.9.7a fails to verify a certificate against a CA
openssl-0.9.7a fails to verify a certificate against a CA
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openssl (Show other bugs)
3.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks: 212183
  Show dependency treegraph
 
Reported: 2006-08-01 04:35 EDT by Jose Plans
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0447
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test_ko : failure using RHEL3's openssl. (3.43 KB, text/plain)
2006-08-01 04:35 EDT, Jose Plans
no flags Details
test_ok : success using RHEL3's openssl. (3.70 KB, text/plain)
2006-08-01 04:39 EDT, Jose Plans
no flags Details
ca-bundle.crt (134.12 KB, text/plain)
2006-08-01 04:42 EDT, Jose Plans
no flags Details
projekte.ibo.de site certificate (1.79 KB, application/octet-stream)
2006-08-01 14:34 EDT, Marco Ceci
no flags Details

  None (edit)
Description Jose Plans 2006-08-01 04:35:26 EDT
Description of problem:
Using the same valid CA set (attached ca-bundle.crt) and the latest version of
openssl on RHEL3, the certificate is checked as not valid.

Version-Release number of selected component (if applicable):
$ openssl version
OpenSSL 0.9.7a Feb 19 2003

How reproducible:
Always.

Steps to Reproduce:
1.openssl s_client -connect https_server:443 -CAfile ca-bundle.crt
  
Actual results:

depth=1 /C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust
External CA Root
verify error:num=24:invalid CA certificate
verify return:0
CONNECTED(00000003)

(see attachement for more details - test_ko.txt)

Expected results:
depth=2 /C=US/ST=UT/L=Salt Lake City/O=The USERTRUST
Network/OU=http://www.usertrust.com/CN=UTN-USERFirst-Hardware
verify return:1
depth=1 /C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust
External CA Root
verify return:1
depth=0 /C=DE/postalCode=35435/ST=Hessen/L=Wettenberg/streetAddress=Im Westpark
8/O=ibo Software/OU=Hosted by Secure-Netz/OU=Hosted by
Secure-Netz/OU=InstantSSL/CN=projekte.ibo.de
verify return:1
CONNECTED(00000003)

(see attachement for more details - test_ok.txt)

Additional info:
The issue seems to be in the x509 validation code. However copying
"crypto/x509/*" , "crypto/evp/evp.h" and "crypto/x509v3/v3_purp.c" from version
0.9.7f to version 0.9.7e fixed the problem.
Comment 1 Jose Plans 2006-08-01 04:35:27 EDT
Created attachment 133378 [details]
test_ko : failure using RHEL3's openssl.
Comment 2 Jose Plans 2006-08-01 04:39:06 EDT
Created attachment 133380 [details]
test_ok : success using RHEL3's openssl.
Comment 5 Tomas Mraz 2006-08-01 04:56:00 EDT
Could you please attach a certificate signed by the 'AddTrust
External CA Root' certificate?
Comment 6 Marco Ceci 2006-08-01 14:34:34 EDT
Created attachment 133427 [details]
projekte.ibo.de site certificate
Comment 17 Tomas Mraz 2007-03-19 11:30:04 EDT
Fixed in openssl-0.9.7a-33.23
Comment 21 Red Hat Bugzilla 2007-06-11 14:41:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0447.html

Note You need to log in before you can comment on or make changes to this bug.