Bug 200913 - RFE: qstat plugin can be added since package already in extras
Summary: RFE: qstat plugin can be added since package already in extras
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nagios-plugins   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-01 15:40 UTC by Andy Shevchenko
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: nagios-plugins-1.4.3-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 14:00:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Shevchenko 2006-08-01 15:40:00 UTC
Description of problem:
qstat package is provided by Fedora extras now. Due to this you could switch on 
the corresponding plugin build at least in devel branch.

Version-Release number of selected component (if applicable):
Last CVS version of the nagios-plugins.

Comment 1 Mike McGrath 2006-08-02 01:10:49 UTC
Will do, let me know when qstat is built and available for FC4/5 for testing. 
They're branched now.

Comment 2 Andy Shevchenko 2006-08-02 11:09:25 UTC
Today I push qstat to make queue for FC[45] and I guess that packages are 
already built.

Comment 3 Mike McGrath 2006-08-10 03:53:00 UTC
I've added check_game to nagios-plugins.  Its being built for devel right now.

Comment 4 Jose Pedro Oliveira 2006-08-11 15:41:11 UTC
Mike,

The nagios-plugins-game needs to require the qstat package.

$ rpm -q nagios-plugins-game
nagios-plugins-game-1.4.3-16.fc5

$ rpm -qR nagios-plugins-game
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libcrypto.so.6
libssl.so.6
nagios-plugins = 1.4.3-16.fc5
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1


strace partial output 
...
[pid  5143] execve("/usr/bin/qstat", ["/usr/bin/qstat", "-raw", ",", "-quake",
"127.0.0.1"], [/* 1 var */]) = -1 ENOENT (No such file or directory)
...


Comment 5 Jose Pedro Oliveira 2006-08-17 14:00:22 UTC
Mike,
Thanks for the fix (nagios-plugins-1.4.3-17).
Closing this ticket.


$ rpm -q --changelog nagios-plugins-game
* Tue Aug 15 2006 Mike McGrath <imlinux@gmail.com> 1.4.3-17
- Added requires qstat for check_game
...


$ rpm -qR nagios-plugins-game
...
nagios-plugins = 1.4.3-17.fc5
qstat
...



Note You need to log in before you can comment on or make changes to this bug.