Bug 200963 - nscd 2.3.6-4 segfaults
nscd 2.3.6-4 segfaults
Status: CLOSED CANTFIX
Product: Fedora Legacy
Classification: Retired
Component: glibc (Show other bugs)
fc4
All Linux
high Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
Brian Brock
LEGACY, 4, NEEDSWORK
:
Depends On: 209881
Blocks: 188761
  Show dependency treegraph
 
Reported: 2006-08-01 16:12 EDT by Peter van Hooft
Modified: 2016-11-24 10:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 15:39:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Replace two occurrences of cnt with idx. (515 bytes, patch)
2006-08-01 16:12 EDT, Peter van Hooft
no flags Details | Diff
glibc-2.4-{10,11} diff (4.52 KB, patch)
2006-09-28 02:16 EDT, Jakub Jelinek
no flags Details | Diff

  None (edit)
Description Peter van Hooft 2006-08-01 16:12:45 EDT
Description of problem:
nscd segfaults

Version-Release number of selected component (if applicable):
2.3.6-4

How reproducible:


Steps to Reproduce:
1.Start with default /etc/nscd.conf
2.
3.
  
Actual results:
Segmentation fault


Expected results:
Should start correctly.

Additional info:
In nscd_conf.c cnt is used twice where that is not correct (cnt is not
even initialized at this point). The variable idx should be used instead.
Comment 1 Peter van Hooft 2006-08-01 16:12:45 EDT
Created attachment 133436 [details]
Replace two occurrences of cnt with idx.
Comment 2 Robert Buffington 2006-09-02 15:02:41 EDT
I have this same problem in Fedora Core 4 with nscd-2.3.6-3 on an x86_64 using 
nss_ldap. (LDAP server is running on another machine.) Other similar bugs 
suggested removing the persistent lines from the nscd.conf file, but that 
didn't help me. It still segfaults at random times.

Have you actually changed those variables and did it make any difference? I 
want to know because I need this fixed. In fact, I think the severity needs to 
be elevated to high because when nscd dies, you can't log onto the system, no 
personal web pages can be located, and incoming mail is sent back with a "user 
unknown" error. That's pretty serious.

I see this bug in a few other places, and it seems to be only an x86_64 
problem. I have other i386 FC4 systems with similar software configurations 
running with no problems.

Sep  1 15:31:02 kernel: nscd[25257]: segfault at 00002aab401fee25 rip 
0000555555561aaa rsp 00000000401ffa80 error 4
Sep  1 16:31:48 kernel: nscd[26936]: segfault at 00002aab401fe085 rip 
00002aaaab1a0750 rsp 00000000401fe5c8 error 4
Sep  2 06:48:09 kernel: nscd[19870]: segfault at 00002aab401fe8c1 rip 
00002aaaae654324 rsp 00000000401ff200 error 4
Comment 3 Peter van Hooft 2006-09-03 03:16:03 EDT
Sorry, but this is on i386. Nscd segfaults immediately.
Comment 4 Jakub Jelinek 2006-09-04 09:24:02 EDT
Fix uploaded to:
http://people.redhat.com/jakub/glibc/2.3.6-5/
Whether the Fedora Legacy project chooses to issue it officially or not is their
decision.
Comment 5 David Eisenstein 2006-09-07 05:36:51 EDT
I would suggest that indeed, this is a critical bug-fix, and that since Jakub
Jelinek supplied .src.rpm for us to use, we ought to use what he provided.

I will go ahead and submit Jakub's .src.rpm package for source QA here, formally.

Note that Jakub's glibc-2.3.6-5.src.rpm package should also fix Bug #188761
(New glibc (2.3.6-3) breaks nis+).

Thanks a bunch, Jakub!
Comment 6 David Eisenstein 2006-09-07 06:35:43 EDT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jakub, would you please verify that your .src.rpm has this as its sha1sum?
Thanks!

Download location:
http://people.redhat.com/jakub/glibc/2.3.6-5/glibc-2.3.6-5.src.rpm

$ sha1sum glibc-2.3.6-5.src.rpm
1e2bb1f51172944a598dc79ef755c9913b764ace  glibc-2.3.6-5.src.rpm

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFE//XJxou1V/j9XZwRAomlAKD1IxiwCT7uAgOMtZJ/3oFMg5uAawCgyMPX
ETE/mhwpkX6SNPdbS8iSe3Q=
=CFEd
-----END PGP SIGNATURE-----
Comment 7 Jakub Jelinek 2006-09-07 06:51:34 EDT
Yes, that's the correct sha1sum.  But, I might have a few further changes in
the next week or so (e.g. the glibc-nscd-addinitgroups.patch patch has a bug),
together with another FC-5 glibc testing update.
Comment 8 David Eisenstein 2006-09-27 22:39:45 EDT
Hi Jakub,

Noticed that you pushed a new glibc for FC-5.  Were there other changes you
had in mind to do here to glibc-2.3.6-5 for FC-4?  If not, we will try using
the glibc-2.3.6-5 that you proposed.

Thanks!    -David
Comment 9 Jakub Jelinek 2006-09-28 02:16:56 EDT
Created attachment 137287 [details]
glibc-2.4-{10,11} diff

Yeah, I meant to add the glibc-2.4-{10,11} changes too.
Attaching diff from CVS.  Basically:
1) glibc-nscd-addinitgroups.patch patch fixed
2) glibc-rh198762.patch renamed to glibc-rh184086.patch
3) 10 other patches added (not sure 100% if all are applicable and/or apply
cleanly to the FC-4 tree)
I'll try to verify that and check it into CVS hopefully this Friday.
Comment 10 Chris Jones 2006-10-03 03:55:20 EDT
This is still a bug in FC5 with the following versions
nscd-2.4-11
glibc-2.4-11

Oct  3 07:23:49 silver kernel: nscd[15245]: segfault at 00002aab40bff13e rip
00002aaaaeb9f025 rsp 0000000040c00100 error 4
Comment 11 David Eisenstein 2006-10-07 07:43:09 EDT
Entering a new Fedora Core 5 bug for Comment #10.
Comment 12 Matthew Miller 2007-04-10 15:39:39 EDT
Fedora Core 4 is now completely unmaintained. These bugs can't be fixed in that
version. If the issue still persists in current Fedora Core, please reopen.
Thank you, and sorry about this.
Comment 13 Sitsofe Wheeler 2007-04-11 02:51:01 EDT
Where was the "new Fedora Core 5 bug for Comment #10" created? The only thing
that I can find is Bug #190431 ...
Comment 14 Sitsofe Wheeler 2007-04-11 02:54:18 EDT
I was blind. Bug #209881 seems to the FC5 version of this.

Note You need to log in before you can comment on or make changes to this bug.