This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 200978 - Unresolvable dependencies (rhnlib) after a fresh install
Unresolvable dependencies (rhnlib) after a fresh install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 18:46 EDT by Marco De la Cruz
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 09:25:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marco De la Cruz 2006-08-01 18:46:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.5) Gecko/20060726 Red Hat/1.5.0.5-0.el4.1 Firefox/1.5.0.5 pango-text

Description of problem:
After a fresh install of RHEL AS4 x86_64 and a first successful
up2date the _second_ up2date after it yields the following:

# up2date --nox --update

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching rpm headers...
########################################

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Name                                    Version        Rel     
----------------------------------------------------------
up2date                                 4.4.69         25                x86_64


Testing package set / solving RPM inter-dependencies...
An error has occurred:

Unresolvable chain of dependencies:
up2date-4.4.69-25                        requires rhnlib >= 1.8.7 


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

See /var/log/up2date for more information


Version-Release number of selected component (if applicable):
up2date-4.4.67-4, rhnlib-1.8.2-1.p23.1

How reproducible:
Always


Steps to Reproduce:
1. Install AS4 x86_64 ("Everything") and register the system
2. up2date --nox --update
3. up2date --nox --update

Actual Results:
Unresolvable chain of dependencies

Expected Results:
A resolvable chain of dependencies

Additional info:
Comment 1 Andreas Holzhammer 2006-08-02 04:42:23 EDT
The same applies for 32bit AS4_x86
Comment 2 Marco De la Cruz 2006-08-02 15:55:52 EDT
I am the person who originally submitted this bug.

I tried "up2date" again today and it worked fine, apparently the
issue was resolved (at least for me).
Comment 3 Bret McMillan 2006-08-03 09:25:38 EDT
This issue has been addressed with the release of the rhnlib erratum.  Should
anyone receive this error again, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.