Bug 201005 - openssl-0.9.7a fails to verify a certificate against a CA
openssl-0.9.7a fails to verify a certificate against a CA
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssl (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 04:10 EDT by Jose Plans
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0297
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test_ko : failure using RHEL3's openssl. (3.43 KB, text/plain)
2006-08-02 04:10 EDT, Jose Plans
no flags Details
test_ok : success using RHEL4's openssl. (3.70 KB, text/plain)
2006-08-02 04:10 EDT, Jose Plans
no flags Details
projekte.ibo.de site certificate (1.79 KB, application/octet-stream)
2006-08-02 04:13 EDT, Jose Plans
no flags Details
This patch should fix the issue (1.81 KB, patch)
2006-08-07 11:17 EDT, Tomas Mraz
no flags Details | Diff

  None (edit)
Description Jose Plans 2006-08-02 04:10:12 EDT
Description of problem:
Using the same valid CA set (attached ca-bundle.crt) and the latest version of
openssl on RHEL3, the certificate is checked as not valid.

Version-Release number of selected component (if applicable):
$ openssl version
OpenSSL 0.9.7a Feb 19 2003

How reproducible:
Always.

Steps to Reproduce:
1.openssl s_client -connect https_server:443 -CAfile ca-bundle.crt
  
Actual results:

depth=1 /C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust
External CA Root
verify error:num=24:invalid CA certificate
verify return:0
CONNECTED(00000003)

(see attachement for more details - test_ko.txt)

Expected results:
depth=2 /C=US/ST=UT/L=Salt Lake City/O=The USERTRUST
Network/OU=http://www.usertrust.com/CN=UTN-USERFirst-Hardware
verify return:1
depth=1 /C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust
External CA Root
verify return:1
depth=0 /C=DE/postalCode=35435/ST=Hessen/L=Wettenberg/streetAddress=Im Westpark
8/O=ibo Software/OU=Hosted by Secure-Netz/OU=Hosted by
Secure-Netz/OU=InstantSSL/CN=projekte.ibo.de
verify return:1
CONNECTED(00000003)

(see attachement for more details - test_ok.txt)

Additional info:
The issue seems to be in the x509 validation code. However copying
"crypto/x509/*" , "crypto/evp/evp.h" and "crypto/x509v3/v3_purp.c" from version
0.9.7f to version 0.9.7e fixed the problem.
Comment 1 Jose Plans 2006-08-02 04:10:14 EDT
Created attachment 133467 [details]
test_ko : failure using RHEL3's openssl.
Comment 2 Jose Plans 2006-08-02 04:10:57 EDT
Created attachment 133468 [details]
test_ok : success using RHEL4's openssl.
Comment 5 Jose Plans 2006-08-02 04:13:53 EDT
Created attachment 133470 [details]
projekte.ibo.de site certificate
Comment 7 Tomas Mraz 2006-08-07 11:17:49 EDT
Created attachment 133741 [details]
This patch should fix the issue

The patch improves handling of certificates with EXFLAG_NSCERT set.
Comment 8 RHEL Product and Program Management 2006-08-18 10:50:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Tomas Mraz 2007-01-12 09:59:37 EST
Fixed in openssl-0.9.7a-43.16.
Comment 14 Red Hat Bugzilla 2007-05-01 13:21:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0297.html

Note You need to log in before you can comment on or make changes to this bug.