Bug 201020 - up2date depends on policycoreutils but doesn't enforce it.
Summary: up2date depends on policycoreutils but doesn't enforce it.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
: 214305 231078 (view as bug list)
Depends On:
Blocks: 218661 240203
TreeView+ depends on / blocked
 
Reported: 2006-08-02 10:36 UTC by Leon brouwers
Modified: 2018-10-20 00:46 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0250
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 23:16:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0250 normal SHIPPED_LIVE up2date bug fix update 2007-04-28 17:55:33 UTC

Description Leon brouwers 2006-08-02 10:36:21 UTC
Description of problem:

up2date now has a dependancy on restorecon but doesn't enforce it.

Version-Release number of selected component (if applicable):
4.4.69-25

How reproducible:
always

Steps to Reproduce:
[root@sly rhn-update]# rpm -Uvh --force up2date-4.4.69-25.i386.rpm 
Preparing...                ########################################### [100%]
   1:up2date                ########################################### [100%]
/var/tmp/rpm-tmp.21010: line 11: restorecon: command not found
error: %post(up2date-4.4.69-25.i386) scriptlet failed, exit status 127

Fixed by:
[root@sly rhn-update]# rpm -Uvh ../RHES4-update3/RedHat/RPMS/policycoreutils-
1.18.1-4.9.i386.rpm 
Preparing...                ########################################### [100%]
   1:policycoreutils        ########################################### [100%]
[root@sly rhn-update]# rpm -Uvh --force up2date-4.4.69-25.i386.rpm 
Preparing...                ########################################### [100%]
   1:up2date                ########################################### [100%]

Comment 2 James Bowes 2006-08-25 17:52:37 UTC
We now test for the existance of restorecon before calling it in the scriplet.

Comment 3 James Bowes 2006-11-09 17:19:45 UTC
Fixed in up2date-4.5.0-1

Comment 4 Pradeep Kilambi 2006-12-07 21:59:01 UTC
*** Bug 214305 has been marked as a duplicate of this bug. ***

Comment 12 Pradeep Kilambi 2007-03-06 20:24:02 UTC
*** Bug 231078 has been marked as a duplicate of this bug. ***

Comment 15 Red Hat Bugzilla 2007-05-01 23:16:44 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0250.html



Note You need to log in before you can comment on or make changes to this bug.