Bug 201025 - rpc.rquotad is not configurable via /etc/sysconfig/nfs
rpc.rquotad is not configurable via /etc/sysconfig/nfs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: quota (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Steve Dickson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 07:07 EDT by Martin Donnelly
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:42:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Donnelly 2006-08-02 07:07:58 EDT
Description of problem:

All NFS related RPC daemons are configurable by creating the appropriate entries
in /etc/sysconfig/nfs with the exception of rpc.rquotad which results in having
to edit the init script directly. 

This ability to configure the NFS RPC daemons port usage is critical in our
environment since we need to firewall these services and editing the init script
is undesireable.

Version-Release number of selected component (if applicable):

quota-3.10-8

Additional info:

The following (untested) patch should do something sensible:

--- /etc/init.d/nfs     2006-05-03 18:56:26.000000000 +0100
+++ nfs 2006-08-02 12:11:40.000000000 +0100
@@ -59,8 +59,10 @@
        fi

        if [ -n "$RQUOTAD" -a "$RQUOTAD" != "no" ]; then
+        [ -n "$RQUOTAD_PORT" ] \
+        && RPCRQUOTADOPTS="$RPCRQUOTADOPTS -p $RQUOTAD_PORT"
            echo -n $"Starting NFS quotas: "
-           daemon rpc.rquotad
+           daemon rpc.rquotad $RPCRQUOTADOPTS
            echo
        fi
        echo -n $"Starting NFS daemon: "
Comment 1 RHEL Product and Program Management 2007-10-19 14:42:13 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.
Comment 2 Martin Donnelly 2007-10-22 06:24:16 EDT
16 months without a response from redhat and then the bug is closed.  Truly
appalling levels of support.

Note You need to log in before you can comment on or make changes to this bug.