Bug 201036 - kernel bootup warning at net/core/dev.c:1177/skb_checksum_help()
kernel bootup warning at net/core/dev.c:1177/skb_checksum_help()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 09:21 EDT by Kenneth Topp
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 19:57:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kenneth Topp 2006-08-02 09:21:59 EDT
Description of problem:

get these on bootup running kernel-2.6.17-1.2505.fc6:

Aug  2 09:10:01 static kernel: BUG: warning at
net/core/dev.c:1177/skb_checksum_help() (Not tainted)
Aug  2 09:10:01 static kernel:  [<c04051ee>] show_trace_log_lvl+0x58/0x159
Aug  2 09:10:01 static kernel:  [<c04057ea>] show_trace+0xd/0x10
Aug  2 09:10:01 static kernel:  [<c0405903>] dump_stack+0x19/0x1b
Aug  2 09:10:01 static kernel:  [<c05b155b>] skb_checksum_help+0x53/0xf7
Aug  2 09:10:01 static kernel:  [<f8dd42da>] ip_nat_fn+0x2e/0x18a [iptable_nat]
Aug  2 09:10:01 static kernel:  [<f8dd4640>] ip_nat_local_fn+0x35/0xa9 [iptable_nat]
Aug  2 09:10:01 static kernel:  [<c05c6557>] nf_iterate+0x2f/0x62
Aug  2 09:10:01 static kernel:  [<c05c668c>] nf_hook_slow+0x38/0x8e
Aug  2 09:10:01 static kernel:  [<c05cf946>] ip_queue_xmit+0x36b/0x3ba
Aug  2 09:10:01 static kernel:  [<c05dd312>] tcp_transmit_skb+0x5e9/0x617
Aug  2 09:10:01 static kernel:  [<c05dede7>] tcp_push_one+0xb9/0xdc
Aug  2 09:10:01 static kernel:  [<c05d50bb>] tcp_sendmsg+0x7a6/0x9bb
Aug  2 09:10:01 static kernel:  [<c05ec60f>] inet_sendmsg+0x3b/0x48
Aug  2 09:10:01 static kernel:  [<c05a800d>] do_sock_write+0xb5/0xbe
Aug  2 09:10:01 static kernel:  [<c05a9ecf>] sock_writev+0xbf/0xd6
Aug  2 09:10:01 static kernel:  [<c04723fd>] do_readv_writev+0x15b/0x25b
Aug  2 09:10:01 static kernel:  [<c0472536>] vfs_writev+0x39/0x49
Aug  2 09:10:01 static kernel:  [<c04729d4>] sys_writev+0x3b/0x93
Aug  2 09:10:01 static kernel:  [<c0403faf>] syscall_call+0x7/0xb
Aug  2 09:10:01 static kernel: DWARF2 unwinder stuck at syscall_call+0x7/0xb
Aug  2 09:10:01 static kernel: Leftover inexact backtrace:
Aug  2 09:10:01 static kernel:  [<c04057ea>] show_trace+0xd/0x10
Aug  2 09:10:01 static kernel:  [<c0405903>] dump_stack+0x19/0x1b
Aug  2 09:10:01 static kernel:  [<c05b155b>] skb_checksum_help+0x53/0xf7
Aug  2 09:10:01 static kernel:  [<f8dd42da>] ip_nat_fn+0x2e/0x18a [iptable_nat]
Aug  2 09:10:01 static kernel:  [<f8dd4640>] ip_nat_local_fn+0x35/0xa9 [iptable_nat]
Aug  2 09:10:01 static kernel:  [<c05c6557>] nf_iterate+0x2f/0x62
Aug  2 09:10:01 static kernel:  [<c05c668c>] nf_hook_slow+0x38/0x8e
Aug  2 09:10:01 static kernel:  [<c05cf946>] ip_queue_xmit+0x36b/0x3ba
Aug  2 09:10:01 static kernel:  [<c05dd312>] tcp_transmit_skb+0x5e9/0x617
Aug  2 09:10:01 static kernel:  [<c05dede7>] tcp_push_one+0xb9/0xdc
Aug  2 09:10:01 static kernel:  [<c05d50bb>] tcp_sendmsg+0x7a6/0x9bb
Aug  2 09:10:01 static kernel:  [<c05ec60f>] inet_sendmsg+0x3b/0x48
Aug  2 09:10:01 static kernel:  [<c05a800d>] do_sock_write+0xb5/0xbe
Aug  2 09:10:01 static kernel:  [<c05a9ecf>] sock_writev+0xbf/0xd6
Aug  2 09:10:01 static kernel:  [<c04723fd>] do_readv_writev+0x15b/0x25b
Aug  2 09:10:01 static kernel:  [<c0472536>] vfs_writev+0x39/0x49
Aug  2 09:10:01 static kernel:  [<c04729d4>] sys_writev+0x3b/0x93
Aug  2 09:10:01 static kernel:  [<c0403faf>] syscall_call+0x7/0xb
Aug  2 09:10:01 static kernel: BUG: warning at
net/core/dev.c:1231/skb_gso_segment() (Not tainted)
Aug  2 09:10:01 static kernel:  [<c04051ee>] show_trace_log_lvl+0x58/0x159
Aug  2 09:10:01 static kernel:  [<c04057ea>] show_trace+0xd/0x10
Aug  2 09:10:01 static kernel:  [<c0405903>] dump_stack+0x19/0x1b
Aug  2 09:10:01 static kernel:  [<c05b1415>] skb_gso_segment+0x89/0x17c
Aug  2 09:10:01 static kernel:  [<c05b1c50>] dev_hard_start_xmit+0x176/0x203
Aug  2 09:10:01 static kernel:  [<c05c01d5>] __qdisc_run+0xdf/0x19d
Aug  2 09:10:01 static kernel:  [<c05b35e0>] dev_queue_xmit+0x13d/0x251
Aug  2 09:10:01 static kernel:  [<c05b7f72>] neigh_resolve_output+0x1cf/0x1fb
Aug  2 09:10:01 static kernel:  [<c05d00e9>] ip_output+0x1c3/0x1fe
Aug  2 09:10:01 static kernel:  [<c05cf957>] ip_queue_xmit+0x37c/0x3ba
Aug  2 09:10:01 static kernel:  [<c05dd312>] tcp_transmit_skb+0x5e9/0x617
Aug  2 09:10:01 static kernel:  [<c05dede7>] tcp_push_one+0xb9/0xdc
Aug  2 09:10:01 static kernel:  [<c05d50bb>] tcp_sendmsg+0x7a6/0x9bb
Aug  2 09:10:01 static kernel:  [<c05ec60f>] inet_sendmsg+0x3b/0x48
Aug  2 09:10:01 static kernel:  [<c05a800d>] do_sock_write+0xb5/0xbe
Aug  2 09:10:01 static kernel:  [<c05a9ecf>] sock_writev+0xbf/0xd6
Aug  2 09:10:01 static kernel:  [<c04723fd>] do_readv_writev+0x15b/0x25b
Aug  2 09:10:01 static kernel:  [<c0472536>] vfs_writev+0x39/0x49
Aug  2 09:10:01 static kernel:  [<c04729d4>] sys_writev+0x3b/0x93
Aug  2 09:10:01 static kernel:  [<c0403faf>] syscall_call+0x7/0xb
Aug  2 09:10:01 static kernel: DWARF2 unwinder stuck at syscall_call+0x7/0xb
Aug  2 09:10:01 static kernel: Leftover inexact backtrace:
Aug  2 09:10:01 static kernel:  [<c04057ea>] show_trace+0xd/0x10
Aug  2 09:10:01 static kernel:  [<c0405903>] dump_stack+0x19/0x1b
Aug  2 09:10:01 static kernel:  [<c05b1415>] skb_gso_segment+0x89/0x17c
Aug  2 09:10:01 static kernel:  [<c05b1c50>] dev_hard_start_xmit+0x176/0x203
Aug  2 09:10:01 static kernel:  [<c05c01d5>] __qdisc_run+0xdf/0x19d
Aug  2 09:10:01 static kernel:  [<c05b35e0>] dev_queue_xmit+0x13d/0x251
Aug  2 09:10:01 static kernel:  [<c05b7f72>] neigh_resolve_output+0x1cf/0x1fb
Aug  2 09:10:01 static kernel:  [<c05d00e9>] ip_output+0x1c3/0x1fe
Aug  2 09:10:01 static kernel:  [<c05cf957>] ip_queue_xmit+0x37c/0x3ba
Aug  2 09:10:01 static kernel:  [<c05dd312>] tcp_transmit_skb+0x5e9/0x617
Aug  2 09:10:02 static kernel:  [<c05dede7>] tcp_push_one+0xb9/0xdc
Aug  2 09:10:02 static kernel:  [<c05d50bb>] tcp_sendmsg+0x7a6/0x9bb
Aug  2 09:10:02 static kernel:  [<c05ec60f>] inet_sendmsg+0x3b/0x48
Aug  2 09:10:02 static kernel:  [<c05a800d>] do_sock_write+0xb5/0xbe
Aug  2 09:10:02 static kernel:  [<c05a9ecf>] sock_writev+0xbf/0xd6
Aug  2 09:10:02 static kernel:  [<c04723fd>] do_readv_writev+0x15b/0x25b
Aug  2 09:10:02 static kernel:  [<c0472536>] vfs_writev+0x39/0x49
Aug  2 09:10:02 static kernel:  [<c04729d4>] sys_writev+0x3b/0x93
Aug  2 09:10:02 static kernel:  [<c0403faf>] syscall_call+0x7/0xb




How reproducible:

always. and I believe my machine will become unstable soon.  with
kernel-2.6.16-1.2289_FC6 (and irqbalance removed) my box entirely stable.  it's
a dual opteron with all ram on one node.  I long ago had to remove irqbalance
due to it causing system to hang after a while.
Comment 1 Kenneth Topp 2006-08-02 09:25:45 EDT
Last bit of details: I use QoS with tc and iptables marking packets as well as
iptables for firewalling and ntp.

[root@static ~]# lsmod 
Module                  Size  Used by
nls_utf8                6272  1 
radeon                112416  2 
drm                    74164  3 radeon
cls_fw                  9728  2 
cls_u32                12548  1 
sch_htb                21384  1 
hidp                   24456  2 
rfcomm                 46760  0 
l2cap                  32400  10 hidp,rfcomm
ipt_MASQUERADE          7936  1 
ipt_REDIRECT            6272  1 
iptable_nat            11908  1 
ip_nat                 22444  3 ipt_MASQUERADE,ipt_REDIRECT,iptable_nat
xt_length               6144  1 
xt_MARK                 6656  1 
iptable_mangle          7040  1 
xt_tcpudp               7296  19 
ipt_LOG                11008  3 
xt_limit                6912  3 
xt_state                6400  3 
ip_conntrack           58080  4 ipt_MASQUERADE,iptable_nat,ip_nat,xt_state
nfnetlink              11416  2 ip_nat,ip_conntrack
iptable_filter          7296  1 
ip_tables              17860  3 iptable_nat,iptable_mangle,iptable_filter
x_tables               18708  10
ipt_MASQUERADE,ipt_REDIRECT,iptable_nat,xt_length,xt_MARK,xt_tcpudp,ipt_LOG,xt_limit,xt_state,ip_tables
acpi_cpufreq           12932  0 
video                  21508  0 
sbs                    20556  0 
i2c_ec                  9216  1 sbs
button                 11152  0 
battery                14596  0 
asus_acpi              21144  0 
ac                      9476  0 
parport_pc             32036  0 
lp                     17512  0 
parport                41448  2 parport_pc,lp
hci_usb                21964  2 
bluetooth              59908  8 hidp,rfcomm,l2cap,hci_usb
usb_storage            74752  0 
snd_via82xx            33072  1 
gameport               20376  1 snd_via82xx
snd_ac97_codec         98616  1 snd_via82xx
snd_ac97_bus            6656  1 snd_ac97_codec
sg                     38820  0 
snd_seq_dummy           8068  0 
ide_cd                 42912  1 
cdrom                  39328  1 ide_cd
snd_seq_oss            38288  0 
snd_seq_midi_event     11912  1 snd_seq_oss
snd_seq                58328  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
i2c_viapro             12948  0 
i2c_core               26000  2 i2c_ec,i2c_viapro
snd_pcm_oss            47008  0 
snd_mixer_oss          21000  1 snd_pcm_oss
uhci_hcd               28308  0 
e1000                 127272  0 
serio_raw              11524  0 
snd_pcm                81836  3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
tg3                   106524  0 
snd_timer              27548  2 snd_seq,snd_pcm
ehci_hcd               36116  0 
pcspkr                  7424  0 
snd_page_alloc         14472  2 snd_via82xx,snd_pcm
snd_mpu401_uart        13336  1 snd_via82xx
snd_rawmidi            29216  1 snd_mpu401_uart
snd_seq_device         12948  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd                    58692  13
snd_via82xx,snd_ac97_codec,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              14176  1 snd
dm_snapshot            21844  0 
dm_zero                 6400  0 
dm_mirror              34000  0 
dm_mod                 62904  6 dm_snapshot,dm_zero,dm_mirror
ext3                  137912  10 
jbd                    63564  1 ext3
sata_promise           16644  4 
sata_via               13316  2 
libata                105120  2 sata_promise,sata_via
sd_mod                 25344  12 
scsi_mod              141928  4 usb_storage,sg,libata,sd_mod
[root@static ~]# lsmod 
Module                  Size  Used by
nls_utf8                6272  1 
radeon                112416  2 
drm                    74164  3 radeon
cls_fw                  9728  2 
cls_u32                12548  1 
sch_htb                21384  1 
hidp                   24456  2 
rfcomm                 46760  0 
l2cap                  32400  10 hidp,rfcomm
ipt_MASQUERADE          7936  1 
ipt_REDIRECT            6272  1 
iptable_nat            11908  1 
ip_nat                 22444  3 ipt_MASQUERADE,ipt_REDIRECT,iptable_nat
xt_length               6144  1 
xt_MARK                 6656  1 
iptable_mangle          7040  1 
xt_tcpudp               7296  19 
ipt_LOG                11008  3 
xt_limit                6912  3 
xt_state                6400  3 
ip_conntrack           58080  4 ipt_MASQUERADE,iptable_nat,ip_nat,xt_state
nfnetlink              11416  2 ip_nat,ip_conntrack
iptable_filter          7296  1 
ip_tables              17860  3 iptable_nat,iptable_mangle,iptable_filter
x_tables               18708  10
ipt_MASQUERADE,ipt_REDIRECT,iptable_nat,xt_length,xt_MARK,xt_tcpudp,ipt_LOG,xt_limit,xt_state,ip_tables
acpi_cpufreq           12932  0 
video                  21508  0 
sbs                    20556  0 
i2c_ec                  9216  1 sbs
button                 11152  0 
battery                14596  0 
asus_acpi              21144  0 
ac                      9476  0 
parport_pc             32036  0 
lp                     17512  0 
parport                41448  2 parport_pc,lp
hci_usb                21964  2 
bluetooth              59908  8 hidp,rfcomm,l2cap,hci_usb
usb_storage            74752  0 
snd_via82xx            33072  1 
gameport               20376  1 snd_via82xx
snd_ac97_codec         98616  1 snd_via82xx
snd_ac97_bus            6656  1 snd_ac97_codec
sg                     38820  0 
snd_seq_dummy           8068  0 
ide_cd                 42912  1 
cdrom                  39328  1 ide_cd
snd_seq_oss            38288  0 
snd_seq_midi_event     11912  1 snd_seq_oss
snd_seq                58328  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
i2c_viapro             12948  0 
i2c_core               26000  2 i2c_ec,i2c_viapro
snd_pcm_oss            47008  0 
snd_mixer_oss          21000  1 snd_pcm_oss
uhci_hcd               28308  0 
e1000                 127272  0 
serio_raw              11524  0 
snd_pcm                81836  3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
tg3                   106524  0 
snd_timer              27548  2 snd_seq,snd_pcm
ehci_hcd               36116  0 
pcspkr                  7424  0 
snd_page_alloc         14472  2 snd_via82xx,snd_pcm
snd_mpu401_uart        13336  1 snd_via82xx
snd_rawmidi            29216  1 snd_mpu401_uart
snd_seq_device         12948  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd                    58692  13
snd_via82xx,snd_ac97_codec,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              14176  1 snd
dm_snapshot            21844  0 
dm_zero                 6400  0 
dm_mirror              34000  0 
dm_mod                 62904  6 dm_snapshot,dm_zero,dm_mirror
ext3                  137912  10 
jbd                    63564  1 ext3
sata_promise           16644  4 
sata_via               13316  2 
libata                105120  2 sata_promise,sata_via
sd_mod                 25344  12 
scsi_mod              141928  4 usb_storage,sg,libata,sd_mod
[root@static ~]# cat /proc/interrupts 
           CPU0       CPU1       
  0:       1634     324402    IO-APIC-edge  timer
  1:          0         13    IO-APIC-edge  i8042
  8:          0          1    IO-APIC-edge  rtc
  9:          0          0   IO-APIC-level  acpi
 14:        471      54548    IO-APIC-edge  ide0
 15:         13       3871    IO-APIC-edge  ide1
169:        121       8809   IO-APIC-level  libata
177:        546      96713   IO-APIC-level  libata, radeon@pci:0000:01:00.0
185:        254     207347   IO-APIC-level  ehci_hcd:usb1, uhci_hcd:usb2,
uhci_hcd:usb3, uhci_hcd:usb4
193:        548     105648   IO-APIC-level  eth1
201:          2        759   IO-APIC-level  eth2
209:          0          0   IO-APIC-level  VIA8237
NMI:          0          0 
LOC:     325948     325947 
ERR:          1
MIS:          0
Comment 2 Reuben Farrelly 2006-08-04 07:18:58 EDT
It's a known problem upstream related to your e1000 and NAT and not specific to
the RH kernels.

See http://www.ussg.iu.edu/hypermail/linux/kernel/0607.1/2689.html and the
thread surrounding it.  I don't think there has been a fix made for it yet..
Comment 3 Kenneth Topp 2006-08-04 15:04:51 EDT
1505 has been very stable for me.    Perhaps this should become a release notes
item so people don't start flooding bugzilla thinking there's an issue.
Comment 4 Kenneth Topp 2006-08-08 19:57:38 EDT
no longer occuring in kernel-2.6.17-1.2530.fc6

Note You need to log in before you can comment on or make changes to this bug.