Bug 201040 - ia64: xen package does not compile
ia64: xen package does not compile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
ia64 Linux
high Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 10:11 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 08:01:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
5/7 patches applies ... two patches do not and require further work. (320.00 KB, patch)
2006-08-02 10:11 EDT, Prarit Bhargava
no flags Details | Diff
8/9 patches apply, one does not (330.00 KB, text/plain)
2006-08-02 13:16 EDT, Prarit Bhargava
no flags Details
9/9 patches ported (80.00 KB, application/x-tar)
2006-08-02 14:03 EDT, Prarit Bhargava
no flags Details
Single unified patch to fix ia64 compilation and functionality (55.72 KB, patch)
2006-08-02 14:07 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2006-08-02 10:11:10 EDT
Description of problem:

The xen package for ia64 does not compile.

Version-Release number of selected component (if applicable): 20060801/xen-3.0.2-22


How reproducible: 100%


Steps to Reproduce:
1.  apply patch in 199686 
2.  attempt to rebuild.
  
Actual results:  Build fails because of missing ia64_intrinsic.h file and other
issues.


Expected results:  Build should succeed


Additional info:

Alex identifies the following csets as _must haves_ for ia64 xen support.

Main ia64 qemu patch
http://xenbits.xensource.com/xen-unstable.hg?cs=42aa63188a88
fix console irq
http://xenbits.xensource.com/xen-unstable.hg?cs=9e12c09a0089
tools build fix
http://xenbits.xensource.com/xen-unstable.hg?cs=5d76b22f80e4
final vti fix
http://xenbits.xensource.com/xen-unstable.hg?cs=b8ec4423cc44
likely important for credit scheduler
http://xenbits.xensource.com/xen-unstable.hg?cs=6d8136d0b302
http://xenbits.xensource.com/xen-unstable.hg?cs=37c8b562a8f1
http://xenbits.xensource.com/xen-unstable.hg?cs=72caf2612e52
annoying, but trivial bug
http://xenbits.xensource.com/xen-unstable.hg?cs=d7a511069a32
use xencons by default
http://xenbits.xensource.com/xen-unstable.hg?cs=79a5833d1266
Comment 1 Prarit Bhargava 2006-08-02 10:11:13 EDT
Created attachment 133480 [details]
5/7 patches applies ... two patches do not and require further work.
Comment 2 Prarit Bhargava 2006-08-02 13:16:53 EDT
Created attachment 133491 [details]
8/9 patches apply, one does not
Comment 3 Prarit Bhargava 2006-08-02 14:03:00 EDT
Created attachment 133496 [details]
9/9 patches ported

Single unified patchset to follow.

P.
Comment 4 Prarit Bhargava 2006-08-02 14:07:15 EDT
Created attachment 133497 [details]
Single unified patch to fix ia64 compilation and functionality
Comment 5 Jeremy Katz 2006-08-02 15:21:46 EDT
Some of these are HV and some are tools, so it's probably better to use the
split up patches and just put them in the appropriate package (kernel or tools)
as needed.

Prarit -- do you want to go ahead and do this or want someone else to coordinate it?
Comment 6 Jeremy Katz 2006-08-02 16:05:21 EDT
Went ahead and integrated these, builds underway
Comment 7 Aron Griffis 2006-08-16 23:06:10 EDT
I think this bug can be closed... Prarit?

Note You need to log in before you can comment on or make changes to this bug.