Bug 201046 - Clamd scanning broken in default configuration
Clamd scanning broken in default configuration
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: amavisd-new (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 10:39 EDT by Johan Kok
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.2-2.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 12:37:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Johan Kok 2006-08-02 10:39:00 EDT
Description of problem:
Since the update from 2.4.1 to 2.4.2 the default scanning with clamd is broken
in the default configuration. The default amavisd.conf file contains a link to
the clamd socket in the wrong directory.

/etc/sysconfig/clamd.amavisd contains:
CLAMD_SOCKET=/var/spool/amavisd/clamd.sock

/etc/clamd.d/amavisd.conf contains:
LocalSocket /var/spool/amavisd/clamd.sock

/etc/amavisd.conf contains:
['ClamAV-clamd',
  \&ask_daemon, ["CONTSCAN {}\n", "/var/run/clamav/clamd"],
  qr/\bOK$/, qr/\bFOUND$/,
  qr/^.*?: (?!Infected Archive)(.*) FOUND$/ ],


Version-Release number of selected component (if applicable):
amavisd-new-2.4.2-1.fc5

How reproducible:
New installations of the new 2.4.2 version of this package. The location of the
 clamd socket in amavisd.conf 2.4.1 package is correct.  

Steps to Reproduce:
1. yum update :)
  
Actual results:
Aug  2 16:30:08 server postfix/smtp[24759]: 2AB1ED6888: to=<x@y.com>,
relay=127.0.0.1[127.0.0.1], delay=7, status=deferred (host 127.0.0.1[127.0.0.1]
said: 451 4.5.0 Error in processing, id=24798-01, virus_scan FAILED: virus_scan:
ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-scanner FAILED: Too many retries to
talk to /var/run/clamav/clamd (Can't connect to UNIX socket
/var/run/clamav/clamd: No such file or directory) at (eval 43) line 268. (in
reply to end of DATA command))


Expected results:


Additional info:
Comment 1 Steven Pritchard 2006-08-02 12:30:13 EDT
Good catch.  I had to recreate the conf patch because of changes in the stock 
config, and I missed that.

I'll push an update ASAP.
Comment 2 Steven Pritchard 2006-08-02 12:37:54 EDT
Fixed version is in the build system now.

Note You need to log in before you can comment on or make changes to this bug.