Bug 201076 - metacity doesn't start as of FC6-Test2-re20060709.7/5.91
metacity doesn't start as of FC6-Test2-re20060709.7/5.91
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 13:26 EDT by Suzanne Hillman
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 10:48:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2006-08-02 13:26:19 EDT
Description of problem:
metacity doesn't start as of FC6-Test2-re20060709.7/5.91; this was determined by
strange behavior in gnome, and when one tries to run metacity as root, you get
the following error:

metacity: error while loading shared libraries: libGL.so.1: failed to map
segment from shared object: Permission denied

Version-Release number of selected component (if applicable):
metacity-2.15.5-6
mesa-libGL-6.5-13.fc6

How reproducible:
Always, at least on the machine I'm trying to use

Steps to Reproduce:
1. Install the system with 20060709.7/5.91
2. Log in as a user at gdm
3. get a confusing error, and continue
4. Open a terminal window, and notice that it's overlapping the gnome-panel at
the top, and that trying to hide all windows complains about a lack of a window
manager.
5. Try to run metacity as root at the command prompt
  
Actual results:
metacity: error while loading shared libraries: libGL.so.1: failed to map
segment from shared object: Permission denied

Expected results:
Metacity should run. Indeed, should already be running.

Additional info:
Installed it today, from bigpapi.boston.redhat.com; seems to be the most recent
build available from that system.
Comment 1 Suzanne Hillman 2006-08-02 13:42:53 EDT
The message referenced in 3 was:

"Do you wish to make default.desktop the default for future sessions?

Your preferred session type Default System Session is not installed on this
computer.

Just _L_og In     _C_ancel     Make _D_efault"

Where I picked the last option in order to continue. May be related?
Comment 2 Matthias Clasen 2006-08-13 10:48:42 EDT
This has been fixed since.

Note You need to log in before you can comment on or make changes to this bug.