Bug 201084 - The new package of autofs renders file maps which are not in /etc unusable.
The new package of autofs renders file maps which are not in /etc unusable.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Moyer
Brock Organ
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 14:11 EDT by Klaus Ethgen
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0416
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:45:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
don't require maps to live in /etc/ (620 bytes, patch)
2006-08-03 16:06 EDT, Jeff Moyer
no flags Details | Diff

  None (edit)
Description Klaus Ethgen 2006-08-02 14:11:11 EDT
Description of problem:
The new package of autofs renders file maps which are not in /etc unusable.

Version-Release number of selected component (if applicable):
Between autofs-4.1.3-168 and autofs-4.1.3-186

How reproducible:
Steps to Reproduce:
1. Setup a box with autofs

2. Create the following map:
 /mnt/bla  /usr/local/maps/bla.map ro

3. Create /usr/local/maps/bla.map with any indirect map

Actual results:
I get a error that /etc//usr/local/maps/bla.map is no map

Expected results:
/usr/local/maps/bla.map should be used as normal file map if it is not
executable.

Additional info:
It is possible to work around the bug with explicit use
 file:/usr/local/maps/bla.map

But this is not expected to be necessary and is also not what has to be done on
solaris (Just that you told in #179325 that the package must be as near to
solaris as possible!)

The bug is located in the autofs-4.1.3-included-maps.patch.

Its somewhat sarcastic: The update last week (#191841) renders the systems so
corrupt that autofs is installed but rpm find it is not so it didn't update to
the new, buggy package.
Comment 1 Jeff Moyer 2006-08-03 15:53:12 EDT
Yes, this is most certainly a regression;  sorry for the inconvenience.

> Its somewhat sarcastic: The update last week (#191841) renders the systems so
> corrupt that autofs is installed but rpm find it is not so it didn't update to
> the new, buggy package.

I'm not sure I understand this part, but I'm going to assume it has nothing to
do with this bug report.  Please correct me if I'm wrong.
Comment 2 Jeff Moyer 2006-08-03 16:06:28 EDT
Created attachment 133583 [details]
don't require maps to live in /etc/

Give this patch a try, if you get a chance.

Thanks!
Comment 3 Jeff Moyer 2006-08-08 15:23:40 EDT
Are you able to give this a try?  Let me know if you need me to create a test
rpm for you.

Thanks.
Comment 4 John Newbigin 2006-09-05 22:28:30 EDT
This patch fixes the problem I have with program maps on RHEL4.4.  There are
plenty of other bug numbers for autofs but this seems to be the fix so I am
posting here.

The RHEL4.4 output of
/usr/lib/autofs/nsswitch /home
program:/etc//home

Correct patched with 133583 output
/tmp/nsswitch /home
program:/home
Comment 5 Robin Humble 2006-09-06 11:30:39 EDT
the patch fixes my problems with RHEL4.4 also.
see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=202860

is there an autofs rpm update for RHEL4 in the pipeline that includes this patch?
Comment 7 Jeff Moyer 2007-01-17 19:20:02 EST
A fix for this issue will appear in autofs version 4.1.3-206 and later.
Comment 9 RHEL Product and Program Management 2007-04-10 11:25:36 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 15 Red Hat Bugzilla 2007-06-11 14:45:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0416.html
Comment 16 Issue Tracker 2007-06-11 15:26:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0416.html



Internal Status set to 'Resolved'
Status set to: Closed by Tech
Ticket type set to: 'Problem'

This event sent from IssueTracker by bhinson 
 issue 113520

Note You need to log in before you can comment on or make changes to this bug.