Bug 201116 - HELP NEEDED xchat version upgrade
HELP NEEDED xchat version upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 183449 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 17:17 EDT by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-02 14:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file for 2.6.6 (20.05 KB, application/octet-stream)
2006-08-02 23:05 EDT, Marc Deslauriers
no flags Details
Patch fixed for 2.6.6 #1 (717 bytes, patch)
2006-08-02 23:07 EDT, Marc Deslauriers
no flags Details | Diff
Patch fixed for 2.6.6 #2 (715 bytes, patch)
2006-08-02 23:07 EDT, Marc Deslauriers
no flags Details | Diff
xchat IM gtkspell fix (561 bytes, patch)
2006-08-21 23:34 EDT, Peter Zelezny
no flags Details | Diff

  None (edit)
Description Warren Togami 2006-08-02 17:17:29 EDT
xchat-2.6.0 is the current version in rawhide, but upstream is at 2.6.6.

Help is needed to port our patches to 2.6.6.  Please attach an updated spec and
updated patches in this report.
Comment 1 Marc Deslauriers 2006-08-02 23:05:58 EDT
Created attachment 133529 [details]
Spec file for 2.6.6
Comment 2 Marc Deslauriers 2006-08-02 23:07:06 EDT
Created attachment 133530 [details]
Patch fixed for 2.6.6 #1
Comment 3 Marc Deslauriers 2006-08-02 23:07:53 EDT
Created attachment 133531 [details]
Patch fixed for 2.6.6 #2
Comment 4 Peter Zelezny 2006-08-03 00:36:57 EDT
It might be worth including this patch for Finnish bugs:

http://xchat.org/files/source/2.6/patches/xc266-fix-fi.diff
Comment 5 Peter Zelezny 2006-08-03 00:42:38 EDT
Note that this choice you've made:
 --enable-spell=gtkspell
turns the input-box to a GtkTextView, and looks kind of ugly (it appears to be
1.5 lines height for some reason). Just thought I'd bring it to your attention.
Using --enable-spell=static might be better, unless there's some specific reason
you've chosen this.
Comment 6 Marc Deslauriers 2006-08-03 07:52:08 EDT
If you use --enable-spell=static, you need enchant as a dependency, which is in
extras, not in core. That means xchat would need to be moved to extras, I think.
Comment 7 Warren Togami 2006-08-03 16:22:02 EDT
Building this into FC6 after test2 is out.
Comment 8 Peter Zelezny 2006-08-03 23:01:28 EDT
About Enchant, yes you're right, but it's a soft (run time) dependancy (i.e. it
uses dlopen() and fails without complaining). Ah well...
Comment 9 Kevin Kofler 2006-08-05 19:36:16 EDT
*** Bug 183449 has been marked as a duplicate of this bug. ***
Comment 10 Kevin Kofler 2006-08-05 19:40:04 EDT
From Bug 183449:
Comment #11 From Christopher Aillon (caillon@redhat.com)    on 2006-08-04 15:40 
EST  [reply]      
  We also really ought to get the multiline patch in. 
http://cvs.fedora.redhat.com/viewcvs/devel/xchat/xchat-2.4.4-multiline-messages.patch?rev=1.1&view=auto

There are also some patches proposed by Rémi Collet there.
Comment 11 Jesse Keating 2006-08-17 18:41:36 EDT
Warren, ping?  Test2 is out, this is on the Target list, can we get this pushed out?
Comment 12 Warren Togami 2006-08-17 18:45:14 EDT
thanks for the reminder, I'll get an initial version in then others can suggest
more improvements.
Comment 13 Warren Togami 2006-08-17 19:16:04 EDT
Hmm... xchat-2.6.6 seems to be unusable with input methods.  It is intercepting
or conflicting with ENTER on commit.  I'd like to avoid pushing with this known
major regression.  Digging a little deeper...
Comment 14 Warren Togami 2006-08-17 19:23:45 EDT
OK, if I build without --enable-spell=gtkspell it fixes input method commit. 
Please suggest additional fixes to the package that hits rawhide tomorrow.  I
will not re-enabled spell checking unless somebody finds a solution to that bug.
Comment 15 Matthias Clasen 2006-08-18 09:29:06 EDT
so, with 2.6.6 in rawhide, should we close this bug ?
Comment 16 Kevin Kofler 2006-08-18 11:03:39 EDT
Maybe the gtkspell problems should get looked at? It would be nice to have 
spell checking (though I'm personally not a big fan of it because I use 4 
different languages and hate having to toggle the spell checker all the time), 
but of course not if it breaks stuff.
Comment 17 Peter Zelezny 2006-08-21 23:34:52 EDT
Created attachment 134612 [details]
xchat IM gtkspell fix
Comment 18 Peter Zelezny 2006-08-21 23:35:42 EDT
This patch may fix it, but the patch is untested and an unknown quantity. It
does use a "private" gtk field.

Note that using gtkspell is not the default, so fixing this isn't a big priority
upstream. Using --enable-spell=static may be the go, as it fixes the IM issue,
makes the input box look better (GtkEntry) and allows optional spelling if you
install libenchant (a soft run-time dependancy).
Comment 19 Warren Togami 2006-08-22 11:11:38 EDT
I'd rather not usea private GTK+ field because the underlying GTK+ could change,
and the gtkspell input text widget does make the client look uglier.

I didn't know static was an optional soft dependency.  If this works fine, then
I suppose we could use static and allow users to optionally install libenchant.
Comment 20 Warren Togami 2006-08-23 18:00:47 EDT
--enable-spell=static will be enabled in tomorrow's rawhide.  Please attach
further proposed fixes to this bug.
Comment 22 Kevin Kofler 2007-06-02 14:28:10 EDT
F7 and Rawhide have 2.6.6 now. And the next version upgrade (2.8.2) is already 
in Rawhide and F7 updates-testing, see bug #224180.
Comment 23 Kevin Kofler 2007-06-02 14:29:24 EDT
Oh, and even FC6 has 2.6.6.

Note You need to log in before you can comment on or make changes to this bug.