Bug 201142 - Keyboard repeats two characters for every keypress
Summary: Keyboard repeats two characters for every keypress
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-03 06:20 UTC by Wade Mealing
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-20 01:28:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wade Mealing 2006-08-03 06:20:12 UTC
Description of problem:

After booting from todays rawhide boot.iso, each keypress, (a-z, backspace,
enter, fN keys) registered in a double press. This was only applicable to linux,
as it worked fine in the syslinux boot loader.

Seemed to behave this way in the terminals, not just anaconda.  This may not be
the correct place to assign it, but I figured it is the place to start as kernel
parameters fixed it.

Version-Release number of selected component (if applicable):
kernel 2.6.17-1.2505.fc6


How reproducible:
Every time.

Steps to Reproduce:
1. Boot from todays rawhide boot.iso
2. at the boot prompt enter: linux text
3. Wait for anaconda to start
  
Actual results:

Anaconda starts, and every key press is registered twice.

Expected results:

Computer to accept a single keypress, as a .. single keypress.

Additional info:

Workaround is to boot with acpi=force noirqpoll

Comment 1 Wade Mealing 2006-08-03 06:29:38 UTC
Correction.
Kernel command line: initrd=initrd.img BOOT_IMAGE=vmlinuz acpi=force irqpoll


Comment 2 Hans de Goede 2006-08-23 05:00:26 UTC
Does this still happen with a current rawhide boot.iso?


Comment 3 Wade Mealing 2006-10-25 02:17:46 UTC
Yeah.

Happens with FC6 Final also.

Comment 4 Wade Mealing 2007-01-24 13:02:04 UTC
Doesnt happen with RHEL 5, or current FC6 iso.

Comment 5 Wade Mealing 2007-02-20 01:24:27 UTC
Confirmed it doesnt happen with FC7T1.

Guess this can be closed.


Note You need to log in before you can comment on or make changes to this bug.