Bug 201157 - RPM update replaces amavisd.conf
RPM update replaces amavisd.conf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amavisd-new (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 05:19 EDT by Dennis Wagelaar
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-05 19:11:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Wagelaar 2006-08-03 05:19:15 EDT
Description of problem:
When yum automatically updates the amavisd-new rpm, it replaces the amavisd.conf
file (saving the old amavisd.conf as .rpmsave).

Version-Release number of selected component (if applicable):
amavisd-new-2.4.2-2.fc4

How reproducible:
Yum automatic update.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Amavisd restarts and uses new "default" config file.

Expected results:
Amavisd restarts and uses site-specific, customised config file.

Additional info:
When amavisd starts using a default config file, it starts sending spam bounces
(i.e. it starts generating spam) and sends any virus alerts to
virusalert@example.com. This has gotten me in trouble with upstream mail operators.
Comment 1 Steven Pritchard 2006-08-03 14:19:18 EDT
The config file is marked %config(noreplace) in the spec.  It should never be 
overwritten.  (On my servers, there is now a /etc/amavisd/amavisd.conf.rpmnew 
as expected.)

The default config in the rpm has $virus_admin and $mailfrom_notify_* set to 
undef and has $final_virus_destiny set to D_DISCARD, so I can't imagine why it 
would be sending any email.

Are you sure you didn't switch from dag or someone else's amavisd-new to the 
one in Extras?
Comment 2 Dennis Wagelaar 2006-08-05 15:11:37 EDT
I indeed switched from dag's amavisd-new rpm (amavisd-new.i386 2.4.1-2.fc4.rf).
The config file location then changed from /etc to /etc/amavisd. Yum probably
did not detect an existing config file?

As for the mails (bounces, alerts) being sent: I was mistaken. These mails were
sent before the installation of the new rpm.
Comment 3 Steven Pritchard 2006-08-05 19:11:54 EDT
(In reply to comment #2)
> I indeed switched from dag's amavisd-new rpm (amavisd-new.i386 
2.4.1-2.fc4.rf).
> The config file location then changed from /etc to /etc/amavisd. Yum 
probably
> did not detect an existing config file?

No, since it isn't in the same location, as far as rpm is concerned they 
aren't the same file.

Cross-repo upgrades are not (and can't be) guaranteed to work.

Note You need to log in before you can comment on or make changes to this bug.