Bug 201175 - Correction needed in description of "pango_layout_move_cursor_visually"
Correction needed in description of "pango_layout_move_cursor_visually"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
: Desktop
: 201174 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 08:56 EDT by Mayank Jain
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 13:09:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 349813 None None None Never

  None (edit)
Description Mayank Jain 2006-08-03 08:56:42 EDT
The current description for function pango_layout_move_cursor_visually reads 
"If count is positive, then the new strong cursor position will be one position
to the right of the old cursor position. If count is _position_ then the new
strong cursor position will be one position to the left of the old cursor position."

While the correct should be 
"If count is positive, then the new strong cursor position will be one position
to the right of the old cursor position. If count is _negative_ then the new
strong cursor position will be one position to the left of the old cursor position."

Notice the words between _ _
Comment 1 Mayank Jain 2006-08-03 09:03:29 EDT
*** Bug 201174 has been marked as a duplicate of this bug. ***
Comment 2 Matthew Barnes 2006-08-03 12:21:10 EDT
API documentation is usually embedded directly in the source code and extracted
with tools like GTK-Doc.  So the problem is not with devhelp, since you can also
see the typo here:

http://developer.gnome.org/doc/API/2.0/pango/pango-Layout-Objects.html#id2970341

Changing component from devhelp to pango.

Thanks for the bug report, though.  It's always good to fix typos in the
documentation.
Comment 3 Behdad Esfahbod 2006-08-03 13:09:29 EDT
Thanks.   Reported upstream, will fix.
Comment 4 Mayank Jain 2006-08-04 02:54:52 EDT
Thanks all :)

Note You need to log in before you can comment on or make changes to this bug.