Bug 201184 - xsane lacks permission to open scanner device
xsane lacks permission to open scanner device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 09:54 EDT by Robert K. Moniot
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 03:27:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpts from /var/log/messages related to USB and xsane (740 bytes, text/plain)
2006-08-03 09:54 EDT, Robert K. Moniot
no flags Details
output of ``rpm -qa -last'' truncated to updates after Aug 4. (5.57 KB, text/plain)
2006-09-01 18:16 EDT, Robert K. Moniot
no flags Details

  None (edit)
Description Robert K. Moniot 2006-08-03 09:54:05 EDT
Description of problem: Using a USB scanner.  When I fire up xsane, it pops up a
box saying "scanning for devices" and then after a short bit says "no devices
available."  If I run it as root, then it finds the scanner.  If, as root, I do
"chmod 666" on the device pointed to by the symlink /dev/scanner-usbdev2.x,
where x is the scanner address, then I can run xsane as a normal user.
So the problem is probably not with xsane but with whatever component of the
system creates the scanner device when the scanner is plugged into the USB port.
 I don't know enough about linux internals to know what component that is.

Version-Release number of selected component (if applicable):
xsane-0.99-2.2.fc5.4

How reproducible:
So far, two out of two times.

Steps to Reproduce:
1.Turn on USB scanner and plug into computer.
2.Start xsane as non-priv user
3.See message "no devices available"
4.As root, do this:
   chmod 666 /dev/scanner-usbdev*
5.Repeat step 2
4.See xsane gui ready for action.  

Actual results:
The chmod step is necessary for non-priv user to run xsane.

Expected results:
Should see xsane gui ready for action without needing the chmod step.

Additional info:
Comment 1 Robert K. Moniot 2006-08-03 09:54:05 EDT
Created attachment 133555 [details]
Excerpts from /var/log/messages related to USB and xsane
Comment 2 Nils Philippsen 2006-08-04 06:03:24 EDT
What kind of scanner (preferably with USB vendor and product id) and which
version of sane-backends do you have?
Comment 3 Robert K. Moniot 2006-08-04 09:31:58 EDT
The scanner is an Epson Perfection 1200U PHOTO USB scanner.
I don't know the USB vendor & product ID.
sane-backends-1.0.17-5.fc5.9
Comment 4 Nils Philippsen 2006-08-04 10:33:48 EDT
Please find out the USB vendor and product ID by running the "lsusb" command
(from the "usbutils" package) as root and posting the output.
Comment 5 Robert K. Moniot 2006-08-04 11:10:19 EDT
[root@pascal ~]# lsusb
Bus 004 Device 001: ID 0000:0000  
Bus 001 Device 001: ID 0000:0000  
Bus 002 Device 006: ID 04b8:0104 Seiko Epson Corp. Perfection 1200
Bus 002 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
Comment 6 Robert K. Moniot 2006-09-01 18:17:00 EDT
Created attachment 135420 [details]
output of ``rpm -qa -last'' truncated to updates after Aug 4. 

The component that changed to fix this bug must be in this list.
Comment 7 Robert K. Moniot 2006-09-01 18:20:28 EDT
The problem has gone away.  Since I didn't use the scanner since about August 3,
I can't tell exactly when the bug was fixed.  It was not anything in xsane since
that has not been updated.  The behavior now is that the device pointed to by
/dev/scanner-usbdev* is owned by whoever is logged in, so xsane has permission
to open it.  Looking at the list, I think most likely the fix came with
kernel-2.6.17-1.2174_FC5 or gnome-session-2.14.3-1.fc5.

Note You need to log in before you can comment on or make changes to this bug.