Bug 20121 - XMMS/Xaudio hangs Enlightenment(Gnome)
XMMS/Xaudio hangs Enlightenment(Gnome)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-31 16:02 EST by amitabha
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-19 15:29:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description amitabha 2000-10-31 16:02:13 EST
I submitted a big report to bugs.gnome.org (big id:  #30136 
on that website)  about xmms
freezing up my window manager on an Athlon processor
running RH 6.2.  After some experimenting,
the following is clear;

1. xaudio/mxaudio does the same thing. Within
one desktop, I can create new windows but cannot
access iconified windows, cannot switch desktops
as the panels are all frozen

2. mpg123 works fine on console and does not interfere with
gnome. So maybe this is a bug with gnome ?

Information about my system is below:
Distribution: Red Hat Linux release 6.2 (Zoot)
System: Linux 2.2.16-3 i686 unknown
C library: glibc-2.1.3-21
C compiler: egcs-2.91.66
glib: 1.2.6
GTK+: 1.2.6
ORBit: ORBit 0.5.0
gnome-libs: gnome-libs 1.0.55
gnome-core: gnome-core-1.0.55-12
Comment 1 Bill Nottingham 2000-10-31 18:49:22 EST
Are you using the stock xmms and enlightenment, or your own builds?

(Disabling sound in enlightenment will probably solve the problem, FWIW.)
Comment 2 amitabha 2000-11-01 05:03:15 EST
I tried your suggestion - I disabled sound in enlightenment, also tried 
a new window manager (sawmill), no change in the problem.
Any X-windows based mpeg3 player freezes gnome up. 


 While it clearly is not a problem with xmms or sound per se,
I should tell you that I am running ALSA with OSS emulation
on a VIA 686 chip. 
Comment 3 amitabha 2000-11-01 05:12:18 EST
I forgot to mention that I am indeed using a stock xmms rpm downloaded
from xmms.org.

I have downloaded the source and compiled it as well - no difference.
Freeamp also causes the same error.

Comment 4 Bill Nottingham 2000-11-13 00:56:31 EST
Are you using the ALSA, OSS, or Esound plugins for xmms?
Comment 5 amitabha 2000-11-19 03:13:08 EST
Sorry - it took me so long to respond to your
question.I have solved the problem without
really knowing what the problem really is,
so you might want to close this bug.

 I installed helix gnome with the latest
gnome-core and that seems to work fine
with the current xmms.

 But just in case, you see someone else with
the same problem, I am using ALSA with OSS emulation.
Thanks!
Comment 6 Bill Nottingham 2000-11-19 15:29:18 EST
OK. We've never seen this problem here, even with ALSA.

It's possibly some difference in the binaries you were using.

Note You need to log in before you can comment on or make changes to this bug.