Bug 201271 - watching logs on brewweb causes Xorg to segfault
watching logs on brewweb causes Xorg to segfault
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 18:40 EDT by Don Zickus
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC 6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 14:08:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log file (23.09 KB, text/plain)
2006-08-03 18:41 EDT, Don Zickus
no flags Details
xorg log file (23.14 KB, application/octet-stream)
2006-08-04 19:39 EDT, Don Zickus
no flags Details

  None (edit)
Description Don Zickus 2006-08-03 18:40:41 EDT
Description of problem:
This is bizarre and I only report this because I was able to reproduce it 30
seconds after it happened the first time.

So I logged on to brewweb to check the status of my compile job.  Went to look
at logs.  Clicked on 'watch logs' and it started filling up my firefox browser
with more info about the job than I cared to know.  After about 10 seconds of
flooding the screen, my screen goes dark, flickers and provides me with a KDE
login screen.  blink a few times.  cursed.  figured I had blown up my
environment again (after only 3 days).  

Logged back in, the first thing I did.. went to brewweb to check those logs
again.  Sure enough same thing happens all over again.  Puts me right back into
the KDE login screen.  

/var/log/messages had this to say about it:
Aug  3 18:34:19 drseuss kernel: Xorg[2777]: segfault at ffffffffaf100f00 rip
0000000000478493 rsp 00007fff385b61f0 error 4
Aug  3 18:34:19 drseuss gconfd (dzickus-3116): Received signal 15, shutting down
cleanly
Aug  3 18:34:20 drseuss gconfd (dzickus-3116): Exiting
Aug  3 18:34:50 drseuss gdm[2774]: pam_krb5[2774]: authentication succeeds for
'dzickus' (dzickus@REDHAT.COM)
Aug  3 18:35:03 drseuss gconfd (dzickus-14936): starting (version 2.14.0), pid
14936 user 'dzickus'
Aug  3 18:35:03 drseuss gconfd (dzickus-14936): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration
source at position 0
Aug  3 18:35:03 drseuss gconfd (dzickus-14936): Resolved address
"xml:readwrite:/home/boston/dzickus/.gconf" to a writable configuration source
at position 1
Aug  3 18:35:03 drseuss gconfd (dzickus-14936): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
Aug  3 18:35:53 drseuss kernel: Xorg[14652]: segfault at ffffffffae400f00 rip
0000000000478493 rsp 00007fff19fedc20 error 4
Aug  3 18:35:53 drseuss gconfd (dzickus-14936): Received signal 15, shutting
down cleanly
Aug  3 18:35:53 drseuss gconfd (dzickus-14936): Exiting



Version-Release number of selected component (if applicable):
xorg-x11-xauth-1.0.1-1.2
xorg-x11-xsm-1.0.1-1.2
xorg-x11-drv-fpit-1.0.0.5-1.2
xorg-x11-drv-calcomp-1.0.0.5-1.2
xorg-x11-drv-voodoo-1.0.0.5-1.2
xorg-x11-font-utils-1.0.1-3
xorg-x11-drv-evdev-1.0.0.5-1.2
xorg-x11-drv-jamstudio-1.0.0.5-1.2
xorg-x11-drv-s3virge-1.8.6.5-1.2
xorg-x11-twm-1.0.1-1.2
xorg-x11-drv-vga-4.0.0.5-2
xorg-x11-drv-elo2300-1.0.0.5-1.2
xorg-x11-drv-magellan-1.0.0.5-1.2
xorg-x11-fonts-misc-7.0-3
xorg-x11-drv-vesa-1.0.1.3-1.2
xorg-x11-drv-tdfx-1.1.1.3-1.3
xorg-x11-server-Xorg-1.0.1-9.fc5.5
xorg-x11-drv-via-0.1.33.2-2
xorg-x11-drv-sisusb-0.7.1.3-1.2
xorg-x11-drv-trident-1.0.1.2-1.2
xorg-x11-xfs-1.0.1-4.FC5.0
xorg-x11-server-utils-1.0.1-1.2
xorg-x11-fonts-100dpi-7.0-3
xorg-x11-proto-devel-7.0-6
xorg-x11-fonts-ISO8859-1-100dpi-7.0-3
xorg-x11-drv-digitaledge-1.0.1.3-1.2
xorg-x11-drv-penmount-1.0.0.5-1.2
xorg-x11-drv-vmware-10.11.1.3-1.1
xorg-x11-drv-mutouch-1.0.0.5-1.2
xorg-x11-drv-savage-2.0.2.3-1.2
xorg-x11-drivers-7.0-2
xorg-x11-xkb-utils-1.0.1-1.2
xorg-x11-drv-ati-6.5.8.0-1
xorg-x11-drv-nvidia-1.0.8762-3.lvn5
xorg-x11-utils-1.0.1-1.2
xorg-x11-drv-keyboard-1.0.1.3-1.2
xorg-x11-drv-mouse-1.0.4-1
xorg-x11-drv-ur98-1.0.0.5-1.2
xorg-x11-drv-void-1.0.0.5-1.2
xorg-x11-drv-i810-1.4.1.3-3.1
xorg-x11-drv-siliconmotion-1.3.1.5-1.1
xorg-x11-drv-palmax-1.0.0.5-1.2
xorg-x11-apps-7.0-1
xorg-x11-fonts-base-7.0-3
xorg-x11-drv-microtouch-1.0.0.5-1.2
xorg-x11-drv-elographics-1.0.0.5-1.2
xorg-x11-drv-dummy-0.1.0.5-1.2
xorg-x11-drv-dynapro-1.0.0.5-1.2
xorg-x11-drv-joystick-1.0.0.5-1.2
xorg-x11-xfwp-1.0.1-1.2
xorg-x11-fonts-Type1-7.0-3
xorg-x11-drv-spaceorb-1.0.0.5-1.2
xorg-x11-drv-aiptek-1.0.0.5-1.2
xorg-x11-xkbdata-1.0.1-7
xorg-x11-drv-acecad-1.0.0.5-1.2
xorg-x11-drv-s3-0.3.5.5-2
xorg-x11-xinit-1.0.1-2.FC5.0
xorg-x11-fonts-75dpi-7.0-3
xorg-x11-drv-hyperpen-1.0.0.5-1.2
xorg-x11-drv-dmc-1.0.0.5-1.2
xorg-x11-drv-magictouch-1.0.0.5-1.2
xorg-x11-fonts-ISO8859-1-75dpi-7.0-3
xorg-x11-drv-fbdev-0.1.0.5-1.2
xorg-x11-drv-summa-1.0.0.5-1.2
xorg-x11-drv-mga-1.2.1.3-1.2
xorg-x11-xdm-1.0.1-2
xorg-x11-filesystem-7.0-1
xorg-x11-resutils-1.0.1-1.2
xorg-x11-drv-nv-1.0.1.5-3.1
xorg-x11-drv-sis-0.8.1.3-1.2
xorg-x11-drv-citron-2.1.5-1


How reproducible:
I did it twice inside two minutes.  but then again, i might have better odds
playing the lottery.

Steps to Reproduce:
login
start firefox
go to brewweb
find a job, find an arch, click on its 'watch logs' button
wait to get kicked out after 5-10 seconds

Actual results:


Expected results:


Additional info:
The fact I did this twice fairly quickly caused me to write this.  Other than
that, if you want to close this saying 'we don't like kde users', then I won't
object.
Comment 1 Don Zickus 2006-08-03 18:41:58 EDT
Created attachment 133590 [details]
log file

In case you guys want this, which you usually do..
Comment 2 Adam Jackson 2006-08-04 18:43:49 EDT
Unfortunately that's just a log from a successful startup.  Can you attach
Xorg.0.log.old after triggering the crash?  That should contain the traceback;
the Xorg.0.log will contain the log from the current session only.
Comment 3 Don Zickus 2006-08-04 19:39:51 EDT
Created attachment 133671 [details]
xorg log file

sorry about that.  you probably won't be to thrilled with this log file either
as the backtrace looks empty.
Comment 4 Matěj Cepl 2006-12-22 10:30:53 EST
Hi, could you also attach your /etc/X11/xorg.conf, and to reproduce the bug
without any /etc/X11/xorg.conf whatsoever (stateless X should kick in and
configure your X automagically)? Or is this bug obsolete because you have
upgraded in meantime and everything works like it is supposed to?

Thanks,

Matěj
Comment 5 Don Zickus 2006-12-22 11:32:42 EST
>Or is this bug obsolete because you have
>upgraded in meantime and everything works like it is supposed to?

Yeah, basically.

Note You need to log in before you can comment on or make changes to this bug.