This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 201336 - rhnpush should check for --nosig before computing md5sum
rhnpush should check for --nosig before computing md5sum
Status: CLOSED WONTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn410
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Satellite QA List
:
Depends On:
Blocks: 218517
  Show dependency treegraph
 
Reported: 2006-08-04 10:14 EDT by John Wregglesworth
Modified: 2013-01-10 03:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 08:18:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2006-08-04 10:14:35 EDT
Description of problem: I was in the middle of using rhnpush to get a nightly of
RHEL 5 into a satellite when it bailed on me because the packages weren't
signed. Unfortunately, this check came after computing the md5sum on 1000's of
packages which takes a while. We need to find a way to check the gpg signatures
before we compute the md5sums of the packages.


Version-Release number of selected component (if applicable): rhnpush-4.9.0-9.rhel4


How reproducible: Always


Steps to Reproduce:
1. Push a lot of unsigned packages into a channel.
  
Actual results: The error about unsigned packages comes after computing the
md5sum of all of the packages.


Expected results: The error about unsigned packages should come before computing
the md5sum of all of the packages.


Additional info:

Note You need to log in before you can comment on or make changes to this bug.