Bug 20134 - Readline commands don't work
Summary: Readline commands don't work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: guile   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-01 06:06 UTC by Torsten Ekedahl
Modified: 2015-03-05 01:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-12 19:17:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Torsten Ekedahl 2000-11-01 06:06:42 UTC
If one tries to use readline commands after having started guile
the control characters are inserted verbatim instead of being interpreted.
This seems to be due to guile being compiled with an incompatible
version of the readline library as I saw the same phenomenon with one
of my own applications and it disappeared after recompilation.

Comment 1 Phil Knirsch 2000-11-12 15:13:41 UTC
I have just checked the problem and it looks like as a link for the
guilereadline library is missing.

So doing by hand a

  ln -s /usr/lib/libguilereadline.so.0 /usr/lib/libguilereadline.so

fixes the problem.

I'll put it in the next build.

Read ya, Phil


Comment 2 Torsten Ekedahl 2000-11-12 15:47:58 UTC
Adding the link doesn't fix it for me:

homealone[2]rpm -qf `which guile`
guile-1.3.4-9
homealone[2]guile
guile> (+ 1 1)
2
[ Pressing Ctrl-p repeatedly ]
guile> ^P^P^P^P
[ And just to be on the safe side: ]
homealone[2]ls -l /usr/lib/libguilereadline.so
lrwxrwxrwx    1 root     root           30 Nov 12 16:40 /usr/lib/libguilereadline.so -> /usr/lib/libguilereadline.so.0
homealone[2]ls -l /usr/lib/libguilereadline.so.0
lrwxrwxrwx    1 root     root           25 Oct 18 18:22 /usr/lib/libguilereadline.so.0 -> libguilereadline.so.0.0.0
homealone[2]rpm -qf /usr/lib/libguilereadline.so.0.0.0
guile-1.3.4-9

Comment 3 Phil Knirsch 2000-11-12 18:33:35 UTC
Have you looked at /usr/share/doc/guile-1.3.4/NEWS file? There is a note saying
that the readline support has changed and that you need to execute the following
commands to enable readline in guile:

    (use-modules (ice-9 readline))
    (activate-readline)

Without them it readline logically doesn't work (as it's not enabled), and
without the ln -s guile won't be able to load the libguilereadline.so as it's
not there (although it's in the guile-devel which is kinda silly... :).

Hope this helps.

Read ya, Phil


Comment 4 Phil Knirsch 2000-11-12 18:34:04 UTC
Have you looked at /usr/share/doc/guile-1.3.4/NEWS file? There is a note saying
that the readline support has changed and that you need to execute the following
commands to enable readline in guile:

    (use-modules (ice-9 readline))
    (activate-readline)

Without them it readline logically doesn't work (as it's not enabled), and
without the ln -s guile won't be able to load the libguilereadline.so as it's
not there (although it's in the guile-devel which is kinda silly... :).

Hope this helps.

Read ya, Phil


Comment 5 Torsten Ekedahl 2000-11-12 19:17:04 UTC
Linking and loading the commands as suggested solves the problem.


Note You need to log in before you can comment on or make changes to this bug.