Bug 201365 - Ready to use mesa CVS srpm
Ready to use mesa CVS srpm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
http://people.atrpms.net/~hdegoede/me...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 12:59 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 16:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to xserver-1.1.1 to make it build with mesa CVS head (1.38 KB, patch)
2006-08-07 12:19 EDT, Kristian Høgsberg
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-08-04 12:59:20 EDT
In a post to fedora-devel-list you wrote:
Planning a backport, yes.  There are apparently enough Intel and <=R200 issues
fixed in CVS that it should just be done whole.  Hopefully 6.5.1 happens Really
Freaking Soon so I don't have to ship CVS bits in FC6.

That said, if updated srpms for mesa and xorg-x11-server were to magically
appear in Bugzilla for me, I certainly wouldn't object ;)

Since I have already created a mesa srpm based on your srpm with the MesaLIbs
part replaced by a very recent CVS checkout, and have addapted / dropped the
nescesarry patches, I thought I might make this work available to you:
http://people.atrpms.net/~hdegoede/mesa-6.5-20060802.src.rpm

I've been using this with great success on an x86_64 in both 64 and 32 bit mode
(I compiled it in a 32 bit chroot and installed the result on my 64 bit Fedora
for use with googleearth).

In the maillistpost you also speak about xorg-x11-server changes, I haven't got
any for you as things work fine for me with the current xorg-x11-server in RawHide.

---

There is one peculiar patch in my SRPM which needs some clarification:
mesa-cvs-r300-smooth-line.patch

This comments this 1 line in r300_renderer.c:
FALLBACK_IF(ctx->Line.SmoothFlag); // GL_LINE_SMOOTH

the result of this is that if an application has requested anti-aliased lines,
which currently are not implemented in the r300 driver, the application gets
normal (not antialiased) lines instead of falling back to the software renderer.

This patch is needed to make googleearth and smc (http://www.secretmaryo.org/)
usable IMHO having none antialiased lines is way better then 2 fps.

The same could be argued for anti-aliased points (the line below this one), but
I haven't encountered any apps using this one yet.

Notice that this change was suggested by upstream and that upstream has even
concidered doing this themselves, they haven;t however because they are planning
to fix this by actually implementing antialiased lines soon.

---

One last note for some reason the CVS version builds its onw glut stuff, so I
remove this in %install
Comment 1 Hans de Goede 2006-08-04 13:03:36 EDT
p.s.

I forgot to mention that I'll be on a short vacation till wednesday, so don't
expect any response from me till then.
Comment 2 Kristian Høgsberg 2006-08-07 12:19:21 EDT
Created attachment 133747 [details]
Patch to xserver-1.1.1 to make it build with mesa CVS head

Patch is not tested.
Comment 3 Hans de Goede 2006-08-22 16:28:45 EDT
Closing this as a CVS mesa snapshot has been released for rawhide.

Note You need to log in before you can comment on or make changes to this bug.