Bug 201373 - updating the kernel gives avc: denied { search } for pid=5516 comm="grubby"
Summary: updating the kernel gives avc: denied { search } for pid=5516 comm="grubby"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-04 17:33 UTC by Jurgen Kramer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 18:52:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jurgen Kramer 2006-08-04 17:33:30 UTC
Description of problem:
Updating the kernel always shows grubby denied messages

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.3.3-20
selinux-policy-2.3.3-20


How reproducible:
always

Steps to Reproduce:
1. Install/upgrade kernel
2.
3.
  
Actual results:
Kernel update/install works just fine but 'grubby' seem to have some problems.

audit(1154712574.821:13): avc:  denied  { search } for  pid=5516 comm="grubby"
name="root" dev=dm-0 ino=8028161 scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:default_t:s0 tclass=dir
audit(1154712638.169:19): avc:  denied  { search } for  pid=7251 comm="grubby"
name="root" dev=dm-0 ino=8028161 scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:default_t:s0 tclass=dir
audit(1154712646.018:20): avc:  denied  { search } for  pid=8287 comm="grubby"
name="root" dev=dm-0 ino=8028161 scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:default_t:s0 tclass=dir
audit(1154712656.195:21): avc:  denied  { search } for  pid=8320 comm="grubby"
name="root" dev=dm-0 ino=8028161 scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:default_t:s0 tclass=dir
audit(1154712900.454:23): avc:  denied  { search } for  pid=10198 comm="grubby"
name="root" dev=dm-0 ino=8028161 scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:default_t:s0 tclass=dir




Expected results:
no avc:  denied  { search } for  pid=5516 comm="grubby" messages

Additional info:
This 'bug' seems to be here for some time.

Comment 1 Daniel Walsh 2006-09-18 19:07:14 UTC
Fixed in selinux-policy-2.3.14-3

Comment 2 Jurgen Kramer 2006-09-19 18:52:36 UTC
Seems to be fixed.


Note You need to log in before you can comment on or make changes to this bug.