Bug 201383 - BuildRequires or BuildPreReq lack glibc-devel
BuildRequires or BuildPreReq lack glibc-devel
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 14:44 EDT by Vilela
Modified: 2013-03-06 00:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 12:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vilela 2006-08-04 14:44:07 EDT
Description of problem:
I´ve been trying to prepare the kernel from Source RPM (version 2.6.9-34.0.2.EL)
and received this error: plase see http://pastebin.ca/114284. Then I installed
the group "Development Tools", but it didn´t solve. Note that I was using
"exclude=*.i386 *.i686 *.i586 *.athlon" in yum.conf. Then I removed those
excludes and tried to prepare again, same error. Then I did "yum install
glibc-devel" (it has chosen an i386 version and installed it). Then the rpmbuild
command ran correctly. I think glibc-devel could be inside the spec file as a
requirement.

Version-Release number of selected component (if applicable):
2.6.9-34.0.2.EL

How reproducible:
I assume always.

Steps to Reproduce:
1.Install a new minimum server on a x86_64
2.download and install the kernel source RPM version 2.6.9-34.0.2.EL
3.run 'rpmbuild -bp kernel-2.6.spec' using a non-root user
  
Actual results:
Please see http://pastebin.ca/114284

Expected results:
Compile without errors.

Additional info:
I think glibc-devel could be inside the spec file as a requirement.
Comment 1 Jason Baron 2007-03-01 15:33:22 EST
hmmm it seems like gcc needs glibc-devel to be installed. So it seems that this
dependency should be there. Are you sure you didn't get an error when installing
the kernel source?
Comment 2 Jiri Pallich 2012-06-20 12:12:28 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.