Bug 201385 - rpm man page doesn't explain --conflicts at all
rpm man page doesn't explain --conflicts at all
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 14:46 EDT by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 18:00:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2006-08-04 14:46:41 EDT
Description of problem:

maybe i'm missing it, but --conflicts is not documented in the rpm man
page... please fix


Version-Release number of selected component (if applicable):

RHEL 4 with all updates
Comment 1 Joshua Jensen 2006-08-04 14:47:55 EDT
Please fix this in Fedora HEAD and RHEL3 as well!!
Comment 2 Jeff Johnson 2006-08-05 03:46:04 EDT
There's no documentation for --conflicts because its not an option, but rather a popt alias
for the rather more complicated option(s) (from /usr/lib/rpm/rpmpopt-x.y.z)
rpm     alias --conflicts       --qf \
  "[%{CONFLICTNAME} %{CONFLICTFLAGS:depflags} %{CONFLICTVERSION}\n]" \
        --POPTdesc=$"list capabilities this package conflicts with"

Popt alias documentation is displayed through
   rpm --help

Comment 3 Paul Nasrat 2006-08-08 18:00:59 EDT
As described the implementation of --conflicts is simply a convenience query
provided through popt.
Comment 4 Joshua Jensen 2006-08-08 20:51:11 EDT
Not a reason to not fix this... the package that owns /usr/lib/rpm/rpmpopt* is
in fact RPM.  This is very much something Red Hat is int he business of
fixing... see BZ #139759.... you even issued an errata for --obsoletes not being
in the man page... it too is a popt alias!!
Comment 5 Joshua Jensen 2006-08-08 20:53:14 EDT
Please re-open this bug for the above reasons.

Note You need to log in before you can comment on or make changes to this bug.