Bug 201410 - networking related softlockup
networking related softlockup
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 17:42 EDT by Iulian Surugiu
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 20:20:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iulian Surugiu 2006-08-04 17:42:03 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. No ideea it just happens and i do not know what is causing it i am just
seeing this and my system is very slow:

Aug  4 21:51:36 bb-root kernel: BUG: soft lockup detected on CPU#0!
Aug  4 21:51:36 bb-root kernel:  <c043dac5> softlockup_tick+0x90/0xa1 
<c0423d44> update_process_times+0x35/0x57
Aug  4 21:51:36 bb-root kernel:  <c0406134> timer_interrupt+0x60/0x98 
<c043db62> handle_IRQ_event+0x23/0x4c
Aug  4 21:51:36 bb-root kernel:  <c043dc07> __do_IRQ+0x7c/0xd1  <c0405035>
do_IRQ+0x63/0x80
Aug  4 21:51:36 bb-root kernel:  =======================
Aug  4 21:51:36 bb-root kernel:  <e09b1105> htb_next_rb_node+0xa/0xe [sch_htb] 
<c04036f2> common_interrupt+0x1a/0x20
Aug  4 21:51:36 bb-root kernel:  <e09a24d2> u32_classify+0x44/0x239 [cls_u32] 
<c05a70f0> skb_checksum+0x4d/0x2a9
Aug  4 21:51:36 bb-root kernel:  <c05ba565> tc_classify+0x27/0x39  <e09b170f>
htb_classify+0xea/0x152 [sch_htb]
Aug  4 21:51:36 bb-root kernel:  <e09b318c> htb_enqueue+0x20/0x18d [sch_htb] 
<c05adabe> dev_queue_xmit+0x106/0x20c
Aug  4 21:51:36 bb-root kernel:  <c05b2168> neigh_resolve_output+0x200/0x236 
<c05c91f2> ip_finish_output+0x0/0x170
Aug  4 21:51:36 bb-root kernel:  <c05ca4eb> ip_output+0x1bf/0x1f8  <c05c91f2>
ip_finish_output+0x0/0x170
Aug  4 21:51:36 bb-root kernel:  <c05c6de4> ip_forward+0x1e2/0x232  <c05c6be0>
ip_forward_finish+0x0/0x22
Aug  4 21:51:37 bb-root kernel:  <c05c5bf0> ip_rcv+0x3a9/0x3d6  <c05c5418>
ip_rcv_finish+0x0/0x1fc
Aug  4 21:51:39 bb-root kernel:  <c05abf54> netif_receive_skb+0x20a/0x265 
<c05ad7af> process_backlog+0x6e/0x126
Aug  4 21:51:39 bb-root kernel:  <c05ad8e4> net_rx_action+0x7d/0x151  <c05abcb4>
net_tx_action+0x5b/0xd3
Aug  4 21:51:39 bb-root kernel:  <c0420703> __do_softirq+0x35/0x7f  <c040508a>
do_softirq+0x38/0x42
Aug  4 21:51:42 bb-root kernel:  =======================
Aug  4 21:51:44 bb-root kernel:  <c04207ae> local_bh_enable+0x61/0x6f 
<c05c007b> ctrl_build_msg+0x57/0x6b
Aug  4 21:51:45 bb-root kernel:  <c06024b3> _spin_unlock_bh+0x5/0xa  <c05c1a74>
rt_garbage_collect+0x17d/0x24f
Aug  4 21:51:45 bb-root kernel:  <c05aeedc> dst_alloc+0x16/0x7a  <c05c2e0c>
__ip_route_output_key+0x4d2/0x702
Aug  4 21:51:46 bb-root kernel:  <c05c304f> ip_route_output_flow+0x13/0x57 
<c05e09bd> udp_sendmsg+0x2c8/0x518
Aug  4 21:51:47 bb-root kernel:  <c05e60aa> inet_sendmsg+0x3b/0x45  <c05a278b>
sock_sendmsg+0xd4/0xef
Aug  4 21:51:48 bb-root kernel:  <c042c16c> autoremove_wake_function+0x0/0x35 
<c042c16c> autoremove_wake_function+0x0/0x35
Aug  4 21:51:49 bb-root kernel:  <c04d8527> copy_from_user+0x54/0x80  <c05a2f8d>
sys_sendmsg+0x192/0x1f7
Aug  4 21:51:49 bb-root kernel:  <c05a3d4f> sys_recvmsg+0x1b9/0x1cd  <c04304a9>
futex_wake+0x9f/0xc7
Aug  4 21:51:50 bb-root kernel:  <c043085f> do_futex+0x276/0x8c9  <c04204d8>
current_fs_time+0x45/0x51
Aug  4 21:51:50 bb-root kernel:  <c0405047> do_IRQ+0x75/0x80  <c05a4430>
sys_socketcall+0x240/0x261
Aug  4 21:51:50 bb-root kernel:  <c0402cb3> syscall_call+0x7/0xb
Aug  4 21:53:08 bb-root kernel: BUG: soft lockup detected on CPU#0!
Aug  4 21:53:08 bb-root kernel:  <c043dac5> softlockup_tick+0x90/0xa1 
<c0423d44> update_process_times+0x35/0x57
Aug  4 21:53:08 bb-root kernel:  <c0406134> timer_interrupt+0x60/0x98 
<c043db62> handle_IRQ_event+0x23/0x4c
Aug  4 21:53:08 bb-root kernel:  <c043dc07> __do_IRQ+0x7c/0xd1  <c0405035>
do_IRQ+0x63/0x80
Aug  4 21:53:08 bb-root kernel:  =======================
Aug  4 21:53:08 bb-root kernel:  <c0423ca3> __mod_timer+0x8a/0x94  <c04036f2>
common_interrupt+0x1a/0x20
Aug  4 21:53:08 bb-root kernel:  <e09a24d5> u32_classify+0x47/0x239 [cls_u32] 
<c05a70f0> skb_checksum+0x4d/0x2a9
Aug  4 21:53:08 bb-root kernel:  <c0602491> _read_unlock_bh+0x5/0xa  <e097d5d1>
ipt_do_table+0x2c1/0x2e8 [ip_tables]
Aug  4 21:53:08 bb-root kernel:  <c05ba565> tc_classify+0x27/0x39  <e09b170f>
htb_classify+0xea/0x152 [sch_htb]
Aug  4 21:53:08 bb-root kernel:  <e08f2603> ip_nat_out+0x3e/0xad [iptable_nat] 
<e09b318c> htb_enqueue+0x20/0x18d [sch_htb]
Aug  4 21:53:08 bb-root kernel:  <c05c91f2> ip_finish_output+0x0/0x170 
<c05adabe> dev_queue_xmit+0x106/0x20c
Aug  4 21:53:08 bb-root kernel:  <c05ca4eb> ip_output+0x1bf/0x1f8  <c05c91f2>
ip_finish_output+0x0/0x170
Aug  4 21:53:08 bb-root kernel:  <c05c6de4> ip_forward+0x1e2/0x232  <c05c6be0>
ip_forward_finish+0x0/0x22
Aug  4 21:53:09 bb-root kernel:  <c05c5bf0> ip_rcv+0x3a9/0x3d6  <c05c5418>
ip_rcv_finish+0x0/0x1fc
Aug  4 21:53:09 bb-root kernel:  <c05abf54> netif_receive_skb+0x20a/0x265 
<c05ad7af> process_backlog+0x6e/0x126
Aug  4 21:53:10 bb-root kernel:  <c05ad8e4> net_rx_action+0x7d/0x151  <c05abd10>
net_tx_action+0xb7/0xd3
Aug  4 21:53:11 bb-root kernel:  <c0420703> __do_softirq+0x35/0x7f  <c040508a>
do_softirq+0x38/0x42
Aug  4 21:53:12 bb-root kernel:  =======================
Aug  4 21:53:12 bb-root kernel:  <c04207ae> local_bh_enable+0x61/0x6f 
<c05c15ab> rt_may_expire+0x9/0x68
Aug  4 21:53:14 bb-root kernel:  <c06024b3> _spin_unlock_bh+0x5/0xa  <c05c1a74>
rt_garbage_collect+0x17d/0x24f
Aug  4 21:53:15 bb-root kernel:  <c05aeedc> dst_alloc+0x16/0x7a  <c05c2e0c>
__ip_route_output_key+0x4d2/0x702
Aug  4 21:53:16 bb-root kernel:  <c05c304f> ip_route_output_flow+0x13/0x57 
<c05e09bd> udp_sendmsg+0x2c8/0x518
Aug  4 21:53:16 bb-root kernel:  <c05e60aa> inet_sendmsg+0x3b/0x45  <c05a278b>
sock_sendmsg+0xd4/0xef
Aug  4 21:53:19 bb-root kernel:  <c042c16c> autoremove_wake_function+0x0/0x35 
<c042c16c> autoremove_wake_function+0x0/0x35
Aug  4 21:53:20 bb-root kernel:  <c04d8527> copy_from_user+0x54/0x80  <c05a2f8d>
sys_sendmsg+0x192/0x1f7
Aug  4 21:53:21 bb-root kernel:  <c0430160> wake_futex+0x42/0x4c  <c04304a9>
futex_wake+0x9f/0xc7
Aug  4 21:53:21 bb-root kernel:  <c043085f> do_futex+0x276/0x8c9  <c04204d8>
current_fs_time+0x45/0x51
Aug  4 21:53:22 bb-root kernel:  <c06024bd> _spin_unlock_irq+0x5/0x7  <c060043c>
schedule+0x526/0x582
Aug  4 21:53:23 bb-root kernel:  <c0405047> do_IRQ+0x75/0x80  <c05a4430>
sys_socketcall+0x240/0x261
Aug  4 21:53:23 bb-root kernel:  <c04d86a2> copy_to_user+0x54/0x6a  <c041ff3e>
sys_gettimeofday+0x27/0x53
Aug  4 21:53:24 bb-root kernel:  <c0402cb3> syscall_call+0x7/0xb



2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Iulian Surugiu 2006-08-09 21:39:26 EDT
Any feedback on this?
Comment 2 Dave Jones 2006-09-10 21:49:39 EDT
Hmm, is this with the latest kernel version?

We may get a better idea of whats going on here when we move to a 2.6.18 based
kernel which has the lock validator.
Comment 3 Iulian Surugiu 2006-09-11 01:35:22 EDT
That was the latest version of kernel available for FC5 at the time i posted the
bugzilla message (can't recall right the version but having nightly yum install
and i got that panic 3 times that day so i guess the latest version of kernel
image was used un boot).

Unfortunatelly that is the most of how I can help it, i do not have access to
that machine anymore because i do not work there for about 1 motnh.
Comment 4 Dave Jones 2006-09-11 20:20:56 EDT
If you manage to reproduce it on any other boxes (especially once we have a
2.6.18 based update), feel free to reopen this, or report a new bug.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.