Bug 201451 - NFS installation based on mounted ISO-file on server
Summary: NFS installation based on mounted ISO-file on server
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils   
(Show other bugs)
Version: 5
Hardware: i386 Linux
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
Depends On:
TreeView+ depends on / blocked
Reported: 2006-08-05 15:38 UTC by Rolf Linder
Modified: 2007-12-03 13:20 UTC (History)
1 user (show)

Fixed In Version: of FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-10 14:01:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Out of network-trace, nfs read error (on FC4) (1.23 KB, text/plain)
2006-08-09 17:51 UTC, Rolf Linder
no flags Details

Description Rolf Linder 2006-08-05 15:38:44 UTC
Description of problem:
An installation via nfs, where the server mounted a iso-file will
freeze...(probably, always when its not a "normal" directory, for example a
mount of dvd-drive or mount of an iso-file).

Version-Release number of selected component (if applicable):
Fedora Core 4: nfs-utils-1.0.7-13.FC4
Fedora Core 5: nfs-utils-1.0.8-2.fc5

How reproducible:

Steps to Reproduce:
1. mount a downloaded iso-file (probably, fc5-dvd iso) -> mount -o loop
/path/to/iso /install
2. share the mounted iso via nfs -> in /etc/exports: /install *(ro,sync)
3. try nfs installation with a client
Actual results:
The installer (anaconda) will start working correctly, without any problems.
then after copying the data it will freeze at the end (where normaly boot loader
will be installed)...I tried this install from current (updated) FC4 and FC5
systemens with the same result...freeze on installation at the end. if you copy
the content of the iso to a directory, then share this directory via nfs it will

Expected results:
complete installation, without freezing

Additional info: 

Comment 1 Steve Dickson 2006-08-08 17:24:16 UTC
Would it be possible to post a bzip2 binary tethereal network
trace? Something like 
    tethereal -w /tmp/data.pcap host <client> ; bzip2 /tmp/data.pcap

Comment 2 Rolf Linder 2006-08-09 17:51:29 UTC
Created attachment 133861 [details]
Out of network-trace, nfs read error (on FC4)

this are the packages which are sent just bevore the freezing....

Comment 3 Rolf Linder 2006-08-09 17:56:44 UTC
So, after 4,5 hours of testing i get some additional information:

the problem exist, when installing a newer FC version than the nfs-server. for
example on my FC4 server i'm not able to cleanly install a FC5 (over mounted
iso, nfs-shared). if you stay on the same version (installing FC5 from FC5 nfs
server) the problem was not seen...also an installation of the new FC5.92
(FC6Test2) worked (via a FC5 server).

so i guess this problem is related to FC4 and cause FC4 is out of official
support (moved to fedoralegacy project) i guess this report will be closed.

the solution to get solved this problem is update to (at least) FC5.

sorry for this late conclusion...

Comment 4 Craig Dunn 2007-09-26 15:17:53 UTC
I've had the excact same problem instaling FC7 from an FC5 nfs server, so it
didn't go away with FC4.

Comment 5 aleahy 2007-12-02 20:14:57 UTC
I was just bitten by this bug when installing a new Fedora 8 system from a
Fedora Core 5 NFS server.  When I mounted the Fedora-8-x86_64-DVD.iso and
exported the mount point via NFS, the installation would hang at seemingly
random points (I tried it multiple times) with a "SQUASHFS error: sb_bread ..."
After extracting the contents of the ISO onto a disk and exporting that
directory via NFS, the NFS installation was able to proceed normally. 

Comment 6 Rolf Linder 2007-12-03 13:20:44 UTC
Have you also checked, that enough RAM is available. I also detected similar
problems when the machine (server) does not have enough ram, since it operates
all the time in the mounted ISO...probably you could provide once information
about free memory (free).

Note You need to log in before you can comment on or make changes to this bug.