Bug 201453 - setroubleshootd eats cpu like crazy and fills console with junk
setroubleshootd eats cpu like crazy and fills console with junk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-05 12:34 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 14:18:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Noise printed to the console, or to the tty where the setroubleshoot service is started (2.86 KB, text/plain)
2006-08-05 12:34 EDT, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2006-08-05 12:34:17 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
My serial console is filled with junk on reboot because setroubleshootd prints
messages about errors as attached.

Steps to Reproduce:
1.Boot up a box now running selinux (permissive), but that formerly had it
disabled and then went through an install from scratch, preserving /home et al
  
Actual results:
Lots of noise to the console, as attached

Expected results:
No such noise, that represents programming errors

Additional info:
Comment 1 Alexandre Oliva 2006-08-05 12:34:17 EDT
Created attachment 133693 [details]
Noise printed to the console, or to the tty where the setroubleshoot service is started
Comment 2 Daniel Walsh 2006-08-22 08:56:23 EDT
Fixed setroubleshoot-0.28-1

There was a 64 bit problem in the code, which has been fixed in this release.
Comment 3 Alexandre Oliva 2006-09-11 12:47:38 EDT
I'm not sure whether this is the same problem or a different one, but 0.41-1
still eats lots of CPU and, worse, it also eats all memory.  It managed to
exhaust the more than 4GB of swap I had on my firewall.  I've relabeled
everything but an alternate / for FC5 that I keep mounted and up-to-date, and it
still doesn't like me for some reason.  This happens to 4 different x86_64
boxes.  I haven't really tried it on x86_32.  Any tips on how to figure out
what's going on?
Comment 4 John Dennis 2006-09-11 14:18:51 EDT
Re: comment #3, this is a different bug, the one in this bug report was 64 bit
specific and has been fixed, I'm closing this bug.

However, what you are seeing Alexandre are two known problems. The memory usage
bug 204274, and cpu consuption is bug 206050.

I'm going to close this as fixed in rawhide because the original bug was a 64
bit specific issue. Alexandre's observation are duplicates of 204274 and 206050.

Note You need to log in before you can comment on or make changes to this bug.